Unable to start mailspring (Wayland)

Installed the latest version from Snap store on Linux Pop!_OS 19.04. I am using Gnome on Wayland.

When invoking the mailspring command from the command line getting:

alex@florianopolis:~$ ELECTRON_ENABLE_LOGGING=true mailspring
/snap/mailspring/346/bin/desktop-launch: line 282: [: /home/alex/../../../.drive/Google: binary operator expected
[12426:0616/151828.452869:WARNING:browser_main_loop.cc(269)] Gtk: cannot open display: :0

I have a directory called .drive in my home that I created.

After waiting for about 5 seconds the command simply exists and the client doesn’t appear.

(Originally posted by pavkam on GitHub.)

I am using Gnome on Wayland.

Mailspring is an electron app. Electron does no support Wayland yet.

cannot open display: :0

Mailspring tries to connect to Xorg, but you’re not running Xorg.

See #2013 and electron/electron#10915.

Running Mailspring on a modern Linux installation isn’t really feasable. You can use Xwayland, but the application will be very blurry if you have a hidpi display.

(Originally posted by WhyNotHugo on GitHub.)

Are there plans to upgrade to Electron 12? I saw your post about the Electron 11 migration, but 12 is out now and will solve this issue.

I’m just anxious that the next upgrade to a newer eletron version will also take a while and I won’t be able to use it native in wayland. :smiley:


@bengotow would be the best one to answer that question. (Please be patient, though. He has a lot of demands on his plate.)

Yes, native Wayland support is available from Electron 12 on only. Please see this PR for details:

Including this will help Mailspring remain one of the only glossy Email clients on the Linux platform, which with Wayland, HiDPI and fractional scaling is visually polished and up to par with commercial operating systems.

Wayland support would be really nice. I don’t think I’m the only one trying to get away from X…

1 Like

While here came the Mailspring flatpak version i use X11 socket (XWayland) to start the app on Wayland (i use Flatseal instead of command line). But really wait for the native Wayland support.

How did u get it working under XWayland?? I have installed the Flatpak version and it doesn´t work for some reason. Have even tried to use flatpak run --socket=wayland com.getmailspring.Mailspring and still no luck, I get this error:
[2 preload-host-spawn-strategy] Running: /app/bin/zypak-helper child - /app/share/mailspring/mailspring --type=zygote
The futex facility returned an unexpected error code.
Failed to generate minidump.⏎
So yeah if u can direct me maybe. Thanks in advanced. Also using Fedora 35