Add Google Account does not finish

Description

I regularly get a message that “Some accounts could not be synced, retrying…” – I am unable to get a more detailed description, for example which accounts have syncing issues.

But considering that my G Suite account was not receiving new incoming emails, I suspected that this was the one with the issues.

In my attempts to get my work email working again, I removed the account and tried to set it up again.

And now I can’t set it up again.

To Reproduce…

Steps to reproduce the behavior:

  1. Mailspring → Add Account
  2. Click on “Gmail or G Suite”
  3. New browser window opens asking me to log in to my account. I do that.
  4. I get asked whether to authorize Mailspring for my email, I accept.
  5. Get a new screen: “You’re all set, go back to Mailspring to finish setup.”
  6. Mailspring still has the “Connecting to Google…” page open. After a few minutes, it changes to “Sorry, we had trouble logging you in. Failed to fetch.” And a button “Try again” which brings me back to the selection for the email provider.

I’ve tried my default browser (Vivaldi), but also Safari and Chrome, it didn’t help.

Expected Behavior

I expect that after step 5 above, Mailspring has connected to the account and syncronised the emails. Or at least gives me new options for how to proceed.

Screenshots


Setup

  • OS and Version: MacOS Monterey 12.3.1
  • Installation Method: It’s been a while, but I’ve used the default installer.
  • Mailspring Version: 1.10.3

Additional Context

I really wish there was an option to get more detailed error messages.

Same issue here. I’ve tried both a Google Workspace and personal Gmail account.