Add option to sync at specific interval

It would be nice to have a setting where one can choose how often there needs to be a send/receive or sync action. Now it does the syncing continuously, so that mails come in instantly.
It would be helpful if one can choose to only sync every hour or so.

Most mail clients have this option, but as far as I can see this option is not present in Mailspring (yet).

(Originally posted by westr029 on GitHub.)

Hey @westr029—thanks for filing this! So this is an interesting one actually. Older Mail clients like Thunderbird and Mac Mail have options for interval-based sync, but almost all modern IMAP providers support the “IDLE” extension that allows a client to wait for new mail rather than polling and asking again and again.

We could add a periodic sync option to Mailspring, but for the vast majority of IMAP accounts you get “instant” new mail notifications essentially for free. For accounts that don’t support that extension, Mailspring asks the IMAP server for the last few messages every 2 minutes and checks for moved / deleted messages every 10 minutes. I think we could definitely add options for those - I’ll leave this open to track that feature!

(Originally posted by bengotow on GitHub.)

Nice to hear that.

I didn’t know about the IDLE extension. But maybe there is a way to kind of ‘store’ these notifications and mails. The thing is that it can be quite distracting if you get these notifications all the time. That is why I would like to have such an option…

(Originally posted by westr029 on GitHub.)

I also would like the option to check email on interval.

I have 2 big office365 mailboxes I use in Mailspring. And all the time Microsoft servers are banning me because I have to much connections/checking active. causing that I can use Mailspring like for 10 minutes, and then must close Mailspring for 30 minutes to make Microsoft happy again.
This is extremely irritating.

Basically, if there doesn’t come an check interval I will need to find another email client, since I cannot keep working like this.


(Originally posted by Kamiware on GitHub.)