After changing the password, Mailspring takes it into account but after few hours or days, it returns to the previous password


I had to change my password of mail webmail (hotmail), so I changed to Mailspring too, however after a few

To Reproduce…

Steps to reproduce the behavior:

  1. Change your password of your mail account
  2. Report the changed password to your mailspring email configuration
  3. Wait a few hours or few days (1 to 3 days).


It will work during this time but after few hours or days (usually 1 day) without doing anything it will return to the previous state by itself, the synchronisation with your webmail becomes impossible and you will have to reconfigure the password of your email on MailSpring and you will have to do this again, and again and all over again. You will no longer able to uses your mail in MailSpring without doing this procedure every time it needs !




  • OS and Version: Windows 10
  • Mailspring Version: image

Please help, even after deleting the mail account then recreating it in mailspring interface the first passwords returns…

Note that I remarked that the problem occurs when you empty the trash or the junk.

I have the same problem - recurring for weeks. I’m a pro subscriber too so that makes it even more frustrating

Hi, comrade
Thanks for the upvote !

Sam problem. I posted about this months ago.

I think this is a keytar issue specifically for Windows[ref]. Is anyone, who’s reporting this issue, not on Windows?

Just to reassure: I’ve been working on the code and I can’t see any way that passwords are sent to mailspring servers, they are stripped from the account JSON before saving.

I managed to find a solution for one individual having this issue. Hopefully, it will help those here:

  1. Completely quit Mailspring (Ctrl + Q OR open the many and click Quit)
  2. Search for Windows Credential Manager
  3. Find the one titled Mailspring/Mailspring Keys and click the drop down
  4. Click Remove and Okay in the warning pop-up
  5. Re-open Mailspring and re-authenticate the account

Hi, unfortunately the bug is still occuring in my Mailspring. The return to previous values doesn’t occur only with passwords but also to some read thread message returning to unread status over and all over again after few days.

I remarked that the bug of password occurs more often after a restart of windows or after emptying the trash or the junk of the whole group of email adresses registered.

I hop this will help you solve this bug.

The last updates didn’t solve the bug however after each reentering password I receive this mail:

What a wrong idea, after doing this I can’t use mailspring anymore !!! Whatever I do impossible to connect any account… All passwords are gone ! I have to reconfigure the whole mailspring now with ALL ACCONTS !

Mr Glenn, please solve this bug instead !


I have to re enter ALL my email accounts now and reconfigure ALL mailspring from ZERO… WHAT A WRONG IDEA YOU GAVE ME…


Like I said, this worked for me. I also tried it just on my other PC without issue.

After removing the keys I get the below

and reconnecting happens without any issue - as below

You didn’t delete the Mailspring/Mailspring Account key by any chance? This is the one that’s linked to your actual mailspring account and removing it may cause issues like the one you reported.

Mr Glenn, please solve this bug instead !

I’m just an average Joe - like you. I’m not an actual developer of the program and sorry, but, I have very little free time to work on these things.

I got this error message after I followed you inrstructions


Then I had no other choice than to follow the instructions on the given link, which told me to erase a whole folder to reinitialize MailSpring