Annoying bug: a mail thread still return to the unread state few days after marking it as read

Description

I have a mail thread in my mailbox that doesn’t stop returning to the unread status. Even if I read it, or mark it as read, after few days it retuns to the unread state.

To Reproduce…

I don’t know. It is difficult to reproduce if you don’t see the bug in your mailspring already.

Expected Behavior

The mail thread should return to the unread status.

Setup

Windows 10
I don’t know where to get mailspring version

Have you verified this is actually a bug with mailspring? For example, it could also be happening either server side or with another client.

Easiest way to test would be to stop using mailspring for a little while and see.

I can’t stop using mailspring for a whole week or 2. That’s not possible.

New update: even after deleting the whole thread, the thread returned back as unread !

Why not? There’s a lot of other clients out there. Without this type of verification you can’t actually verify that this is a bug with mailspring.

This is not reasonnable I use mailspring for more than 13 emails, I can’t spend my time reconfigurating a client and stop using Mallspring it for 3 weeks. Moreover, Mailspring can just open itself by accident during a reboot of the computer, or a mistake by myself. This is not realizible.

And secundly, 1o there’s not a lot of other free mail clients, there’s only thunderbird, and I already uses it for another purpose.

I reproduced the bug in another mail address, the problem occurs with threads ! Maybe when we reply to a mail at the middle of the thread

Maybe try to reset the Cache in the account settings. Does this correct the behavior?

Ok I will try this. But I don’t think it will work.
It could take 1 to 3 weeks to see the results. So be patient.

Came here to file a ticket about the same issue, and found this existing ticket.

I can verify, Mailspring is unable to mark a new message as unread, when it appears consolidated in, or appended to an email thread. That problem occurs in all my 3 installations of Mailspring: KDE Neon (Linux), Mac OS X, Windows 11. Email provider is Google Mail.

To clarify, the problem in my case is not that a thread automatically switches back to unread state after a while, but when a new message appears in that thread. And when that happens, it’s impossible to switch the thread to unread state, when that new message is opened. I already tried clicking on every single message of that entire thread. It doesn’t work.

The only workaround is to manually mark the entire thread as unread via context menu, and then mark it as read, which is super tedious to do, because that bug happens for every single email thread.

As suggested here, I just reset the cache and will observe if that problem comes back again. Since it always happened to me on all platforms, I doubt that it will fix the problem. I’m also sure that I had to reset the cache a while ago for different reasons, and the problem came back.

Some guidance on how to troubleshoot and sending application logs etc would be appreciated.