Archived Messages going to trash instead


I’m calling it quits, Mailspring. I’ve been hunting for messages I Sent and Archived yesterday. When I tried searching for those messages (that I knew I sent) they didn’t show up at all, so I checked my trash: turns out for the past few days any message I’ve sent and archived has ended up in my Trash folder, waiting to be deleted. When I right click those messages and select Archive, they still appear in my Trash folder. I’m finding many other really crucial messages here in my trash folder, which I suppose have been slowly getting deleted. Ironically, months ago I was searching for an archived message that wouldn’t come up–when I clicked the search spam and trash option, it appeared! I assumed it was a bug, but I guess that’s why this has been happening!

As promising as Mailspring appears to be on the surface, I can’t do this anymore. The constant disconnecting of my accounts, regular freezing that requires a restart to fix, and now this: potentially losing months worth of important, archived emails because I assumed this was a functioning application! Every day I get the reminder “Consider buying Mailspring Pro” and I want to support this project–I’ve tried using it for nearly a year–but I can’t justify supporting something when I have no confidence in it’s improvement! Which is a shame because the other features offered should be the gold standard for email clients. And I can’t risk having important–very important–email deleted.

Beyond frustrating, especially in a world where all other email client developers seem to have no idea what they’re doing and/or how to simply keep their users happy (looking at you, Spark Desktop).

To Reproduce…

Steps to reproduce the behavior:

  1. Send and Archive a message
  2. Check Trash folder

Expected Behavior

My messages are archived, not put in trash



  • OS and Version: MacOS Ventura 13.5.1
    • Installation Method: app?
  • Mailspring Version: 1.11.0-6193b33c

Additional Context

Same here, unfortunately, Mailspring was destructive to my data and I switched back to Spark

Same here, i not using it until this error will be repaired