Attached Files Not Sent (Add Upload Progress Bar)

on Windows 10 - Mailspring 1.6.0 (I already had this same problem several times with version 1.5.7)

1/ I am writing a new message or I am writing a reply
2/ I attach files. (small files size: less than 1 MB)
I select several files at the same time, only 2 or 3 files.
the problem occurred with files .pdf or .png

3/ then in the “new message” window or when I answer, I can see the attached files

4/ when I click on the “Send” button, the message is sent without including the attached files
I can also see in the “Sent” folder, that this message has no attached file

The trouble is that this problem is not repeated (the other days), and I do not know why there is this problem.

when the problem occurs, I’m blocked. I tried to solve it:
1/ I restart Mailspring, but when I send again message with attached files. I have the same situation, the message is sent without the attached files.

I don’t think it’s related to a server problem, on the email side because that same day and same time, when I use another mail client with the same sending settings , I don’t have this problem and the attached files (the same ones) are included in the sent message.

This problem is not regular or not every time. This problem is with all my email accounts but irregularly.

(Originally posted by franco27 on GitHub.)

Hey! Thanks for reporting this, this is really interesting. It sounds like this is happening with a specific couple attachments that you have? I think this might be due to the permissions on the files, or something about their filenames or paths. Could you post the full paths to the files you dropped on the composer here? Curious whether something about them is throwing off the app.

I agree it’s definitely not a server problem - I think Mailspring should also be complaining if the files do not exist when it goes to send, so I think it might be a permissions issue of some sort.

(Originally posted by bengotow on GitHub.)

This time it was with 2 files .png small sizes (25 KB and 490 KB). these files are located in the “images” folder of Windows10. (C:\Users\francois\Pictures\2019-03-25_14-12-26.png)

or C:\Users\francois\Documents\ShareX\Screenshots\2019-03\2019-03-03_17-04-15.png

Last time with 2 PDF files that I couldn’t send (still less 1MB)
(C:\Users\francois\Desktop\feuille_fevrier.pdf) scanned and created by printer CANON

What I don’t understand is, when there is a problem, on the same day or at the same time, I can repeat the problem. (impossible to send attached files)

I even assumed that this problem only occurred when I selected several files at the same time in the file explorer. But no because I imported 1 file and then another file, and the problem was still there when sending.

And another day, I will be able to send attached files without this malfunction. Usually at the same locations.

(Originally posted by franco27 on GitHub.)


I’m also seeing this on Ubuntu 18.04 with the Mailspring 1.6.0 Snap on a Google account. For me this is isolated to the “New Message” compose window. Adding attachments in an existing thread seems to work.

In the “New Message” window everything looks like it works, including showing a preview of the image, etc. However there is no attachment when the message is actually sent.

I’m happy to provide any additional details that might help.

Mailspring is a fantastic email client. Thank you for your effort!

(Originally posted by mikerisher on GitHub.)


When uploading files as attachment, no progress bar is shown. Even there are no alerts to clarify that if my attachments are uploaded or not. Sometimes recipient is receiving the mail without the attachment I uploaded.

Please add a progress bar for file attachments.

(Originally posted by ayanb1991 on GitHub.)

I think the preceding post is the key!

Files are not being attached because they’re not done being uploaded.

Implementing a progress bar or other indicator would almost certainly solve this issue.

Hey @Phylu, this might be a good one to attack?

I just had a similar issue yesterday. I tried to attach two images which had the same prefix in the name and only one of the two was attached to the e-mail. So I think it is not something that a progress bar can solve. I am not sure if I am able to figure out a solution, but I can certainly give it a try.

1 Like