Automatic BCC not working in replies


I have set up an automatic BCC using Preferences > Accounts. This is working when I compose a new message. But I never see the automatic BCC when replying to messages, even though this help page says: “When you start composing a new email from this account, or reply to an email using this account, your message will be pre-populated with the address(es) you listed in the CC or BCC field.”

To Reproduce…

Steps to reproduce the behavior:

  1. Preferences
  2. Click on accounts
  3. Add automatic BCC address
  4. Go to any email
  5. Click on “Write a reply”

Expected Behavior

I expected the automatic BCC address to be present in the BCC field of the reply.

Actual Behavior

The reply has a blank BCC field.


  • OS and Version: macOS 11.4
    • Installation Method: installer from Mailspring website
  • Mailspring Version: 1.9.1

Additional Context

I am using a Gmail account associated with G Suite.

I can’t confirm this here (Mailspring 1.9.1 on linux Kubuntu 20.10), on IMAP or GMail accounts. The requested email always seems to turn up in the BCC field.

(I don’t usually use this option and enabled it only to check, so I don’t know if that would make a difference, but it definitely worked as expected here.)