Calendar attachment cannot be downloaded


I received a calendar invite in an IMAP account but the button to download the attachment is grey and I cannot get the calendar. I can see the invite in the log “BEGIN:VCALENDAR…” but the previous message in the log is “12516 [2024-01-08 10:31:33.769] [calContacts] [info] Received calendar event but it has no start time?”

I don’t know how this is relevant however there is a start time. It also references my timezone in my google account, however this is not a google account (and in fact I tried using this will only the IMAP account).

There seems to be a bug in handling the time in the calendar, possibly based on assumptions on timezone and on using google calendar.

There should be a switch in config to not handle calendar invites at all and simply get them as attachments. At the same time, specific handling of any type should not prevent using the attachment as normal despite the handler not working properly.

To Reproduce…

Steps to reproduce the behavior:

Receive a calendar invitation in an IMAP account.

Expected Behavior

That there is the possibility to save as a file any attached file type, including calendar invites.



  • OS and Version: Windows 11 Home 22H2 22621.3007

    • Installation Method: windows installer
  • Mailspring Version:1.13.3-9a7e1a78

Additional Context

Only seems to happen with my IMAP account

Just in case you have that issue, I solved it by opening the message source and copying the relevant part (look for mime calendar base64). The in WSL:

cd /mnt/c/Users/<your user>/Downloads
cat >invite.base64.vcs<<EOF
base64 -d invite.base64.vcs > invite.vcs

then in windows file explorer go to downloads and open the file (in my case I had to open it in the “old outlook” as according to the program “this feature was not available yet”). Maybe that helps diagnose the bug. In any case failing to handle “special attachments” should not disable saving as an ordinary attachment.


1 Like