Cannot send mail ­— Connection error: unable to connect to the server (new to 1.8.0)

How can I request registration data to be sent here?
It may be able to give some more information to solve this problem.

Thank you

Thanks @CodeMouse92 , great to know this detail can help.

Please feel free to post here if I can assist any further with a test or logging. I’ll watch for updates.

I cant send any email with file included.
Any emails without file - are sending without any problem.
Mailspring tells me that it cant connect to specified address and port/
I use internet email server and local server too.

Mailspring version 1.7.8-13635bcf

3908 [2020-06-29 14:35:19.667] [foreground] [info] - Sending draft
3908 [2020-06-29 14:35:19.667] [foreground] [info] – Identified sent folder: &BB4EQgQ,BEAEMAQyBDsENQQ9BD0ESwQ1-
3908 [2020-06-29 14:35:19.680] [foreground] [info] – Sending a single message body to all recipients:
3908 [2020-06-29 14:35:19.735] [foreground] [info] -X An SMTP error occurred: ErrorConnection LibEtPan code: MAILSMTP_NO_ERROR
3908 [2020-06-29 14:35:20.185] [foreground] [error] [local-3e00198b-43a9] – Failed ({“debuginfo”:“ErrorConnection”,“key”:“send-failed”,“retryable”:false,“what”:“Unknown exception”}). Changing status to complete

(Originally posted by skobanev on GitHub.)

FYI - An update on my earlier feedback.

For separate reasons, I ended up with a new machine, and configured MailSpring on it. From this new machine, I am able to send email from the previously ‘affected’ mailbox with no issue or error. I don’t know why it is different, settings are the same, but MailSpring is working perfectly on this new computer. Just want you to be aware.

OS: PopOS 20.10
Old, “affected” computer: HP Envy Spectre XT 13
New computer, works perfectly: Thinkpad X390

I can’t imagine hardware makes any difference in sending mail, but I’m pleased that MailSpring works fully on the new computer.

Hmm, I wonder if there was a problem with the network card.

Since some other people have confirmed, I’ll leave this open for now.