Cannot sign into Mailspring on welcome screen

On my new laptop, after installing Mailspring, I’m unable to sign in on the welcome screen. I get stuck at the “Signing In…” screen and it doesn’t proceed any further.

Sound like you have installed Mailspring before. I noticed myself that if I click through too quickly the app freezes on certain screens.

Quit/restart the app then click through the setup screen with a second or two between each click. Does this solve your problem?

I have tried that and still get stuck. I even tried deleting the ~/.config/Mailspring folder, deleting the keys from the keyring, uninstalling mailspring, rebooting and installing it again and it still doesn’t work

Edit: wrong keyboard shortcut

You say it gets stuck on the Signing in... screen. Can you proceed without signing in at all?

If that works you can try signing in afterwards from the settings.

Before that though. If you can provide any logs that would help identify the issue (ie. any errors in the console tab of the developer tools [Ctrl + Shift + i on windows - at any point of the process])

PS. not a mailspring dev, just trying to help :grin: