Can't add second account on Ubuntu 20.04 and up


I’m running Ubuntu 21.04 but this has been happening on earlier versions also, first found on 20.04. I can configure first email account with no issue, but when i try the second account it goes through the motion but when you click on Done… it never shows up on the account list.

To Reproduce…

Steps to reproduce the behavior:

  1. install on Ubuntu clean version.
  2. setup mailspring with first email account.
  3. setup second email account
  4. when you click on Connect Account, it makes it look like a success.
  5. go to Settings and Accounts and notice no second account.

Expected Behavior

To configure multiple email account like on MacOS or Windows




  • OS and Version: Ubuntu Linux 21.04 & Ubuntu Linux 20.04
    • Installation Method: deb
  • Mailspring Version: 1.9.1

Additional Context

more info on old case in Github

Sorry to hear you’re still having this issue! Hopefully we can get this resolved soon. (Be advised, we have a lot of bugs, and extremely limited development time. It’s all volunteers.)

No worries… Thank You for the great email app!!!

Hi, I’m having the same issue on my 2 PCs with Ubuntu 18.04 and 20.04.
I never tried this feature before but today I tried to connect two accounts and it didn’t worked.
If I connect them individually everything works so it’s not a configuration problem.
Thanks for all your effort and I hope you can solve this issue soon.