Can't reply to email chains


I synced the client using IMAP. I can send emails but can’t reply to certain emails and the application gives the error of server being inaccessible. I have tried to send another new email at that very second and it worked. the issue is reproduced when I try to hit send on that same error-prone email multiple times


Steps to reproduce the behavior:

  1. Replying to email chains synced via IMAP
  2. See error

Email was supposed to be sent but got this error instead



  • OS and Version: Windows 10
  • Mailspring Version: 1.7.6

(Originally posted by ZeeshanSultan on GitHub.)

Wow I think this is a new one! What email provider are you using? I think that the “Connection Error” is probably a bit of a red herring and your SMTP gateway is seeing something it doesn’t like in the outbound message and terminating the connection. Maybe very strict spam rules or something?

(Originally posted by bengotow on GitHub.)

I am using, cPanel with the pre-configured mail server on my own VPS. Just sent the same mail from webmail (Horde) and it sent just fine so I am confident if there was any spam rule it would’ve been triggered. In fact, the client sent other emails just fine. Only some particular ones get this error.

As a side note: Until we have a stable release we can actually have a debug log option enabled for the client.


Turned on debug flags, it lost all my mails and preferences but after resyncing sent the same mail. And voila It has been sent.

Update 2

Happening Again is there a way we can check connection status since it’s working for other mail

(Originally posted by ZeeshanSultan on GitHub.)