Config JSON Error - Can't Connect to Any Services


When starting (after boot), there was a pop-up stating “config.json” error, and now I couldn’t connect any services anymore, even after cleaning and re-installing the app. I tried to read the community and the issues tab on GitHub, or even browse “mailspring” on Twitter, but I don’t see anyone complaining about this issue. Also, there is a firewall pop-up after I reinstall the app, and I did press “Allow”, so I assume its working, supposedly.

To Reproduce…

Steps to reproduce the behavior:

  1. Open the app.
  2. Skip the Mailspring ID registration form.
  3. Click services icon
  4. Gave permission
  5. The Mailspring app just keeps loading, and the authentication doesn’t come through. Stated, “Sorry, we had trouble logging you in”.
  6. Close the app by right-click on the tray icon.

Expected Behavior

The Mailspring app will be reset to the vanilla, and the account will be synced, again. Fresh from the oven.


  • OS and Version: Windows 11
    • Installation Method: Previously the app updated on its own, and the one I re-installed was acquired from GitHub.
  • Mailspring Version: 1.13.2

I suggest you try deleting your Mailspring folder with the config.json and set it up again.

First, quit Mailspring and identify where it is storing it’s data:
Mac: ~/Library/Application Support/Mailspring
Windows: C:\Users<Your User>\AppData\Roaming\Mailspring
Linux: $XDG_CONFIG_HOME/Mailspring or ~/.config/Mailspring

Then make a backup of the folder and delete it. Then start marketing again

Nope, still not working…

I cleaned the folder, re-authenticate, re-clean, re-install, still not working…

What do the logs say?

UI Logs:

  1. Go to “Developer” > “Toggle Developer Tools”
  2. Chose the “Console” tab
  3. Press “Clear Console” (Ctrl + L)
  4. Reproduce the Issue
  5. Do a right click inside the console and click “Save as”
  6. Clear any personal information from the debug file that you now have created
  7. Attach the file here

Mail sync Logs:

  1. Go to your Mailspring User Directory:
    • Mac: ~/Library/Application Support/Mailspring
    • Windows: C:\Users\<Your User>\AppData\Roaming\Mailspring
    • Linux: $XDG_CONFIG_HOME/Mailspring or ~/.config/Mailspring
  2. Look for the file mailsync-xxxxxxxx.log wheras the xxxxxxxx denote the internal id of your e-mail account
  3. Attach the file here

I couldn’t find any file that begin with mailsync on that Mailspring folder…

And I couldn’t launch the Mailspring at all…

I could only reach the “Connect an email account” screen, then as I couldn’t login to any, I couldn’t enter Mailspring at all…