Couldn’t set up my @live.ca Outlook Email account

Description

Couldn’t add my @live.ca account in mailspring with the App passwords or the Microsoft Account password.

I turn on “Two-step verification” on my @live.ca account.
I created a new App password in Microsoft Account Security.
I tested the App password works in Outlook and Thunderbird.
The error message is:

Connection Error - Unable to connect to the server / port you provided. (IMAP)View Log

The error log:

----------IMAP----------
connect <mailcore::IMAPSession:004FF530>
* OK The Microsoft Exchange IMAP4 service is ready. [WQBUADMAUABSADAAMQBDAEEAMAAxADQAMAAuAEMAQQBOAFAAUgBEADAAMQAuAFAAUgBPAEQALgBPAFUAVABMAE8ATwBLAC4AQwBPAE0A]
ssl connect outlook.office365.com 993 2
OpenSSL version: OpenSSL 1.1.0f  25 May 2017
1 CAPABILITY
* CAPABILITY IMAP4 IMAP4rev1 AUTH=PLAIN AUTH=XOAUTH2 SASL-IR UIDPLUS ID UNSELECT CHILDREN IDLE NAMESPACE LITERAL+
1 OK CAPABILITY completed.
connect ok
login
2 LOGIN "USERNAME@live.ca" *********

To Reproduce…

Steps to reproduce the behavior:

  1. Go to ‘menu’
  2. Click on ‘Add Account’
  3. Scroll down to ‘Outlook.com / Hotmail’
  4. Adding USERNAME@live.ca by follow How to access your Live.ca (Outlook.com) email account using IMAP
  5. Click on ‘Connect Account’
  6. See error ( it took about 30 seconds spinning, then gave the error message)

Expected Behavior

It should able to connect to the account.

Screenshots

The error message is:

It showed Type: Successful sync in the Microsoft Account recent activity page.

Setup

  • OS and Version: Windows 11 Pro 23H2 build 22631.3447
    • Installation Method: installer MailspringSetup.exe
  • Mailspring Version: 1.13.3-9a7e1a78

Additional Context

Mine stopped working as well.

Same issue here, but with a @hotmail.com account. I managed to add the account after several attempts. However, following an app restart, it fails to authenticate, and I am faced with the same issue again.
Screenshot 2024-05-17 203721
Screenshot 2024-05-17 203753