Disable Automatic Check for Updates

Hi all,
is there a way to configure mailspring so that it doesn’t automatically check for new updates?
I’d prefer check and upgrade it by hand, so I can test the new version and if there are any issue I could downgrade to previous one.

I installed Mailspring on a Windows 7 machine used by various users and this morning they encounter the 1.10.x update bug you are discussing about in an other topic here. For my needs would be better to stay with a “stable” solution and test any upgrade by myself before let users “alone in the dark”.
I know old versions will not be supported, but if I will encounter any bug I’ll upgrade to the current version before search or ask for support.

Disable auto update could not be enough because some user could click and confirm for upgrade. Manual check should be a better solution.
Any way to achieve it?

Thanks in advance!

2 Likes

[[Solved]] Please check out this one for v1.10.0 : Database Error and unable to launch app after installing V1.10.0 - #31 by working-name

Hope this helps.

Thank you but that’s not my question: I already solved by downgrading to version 1.9.x.
I also followed that guide to point mailspring launcher to that specific version.
Anyway Mailspring still suggests 1.10.x upgrade.

Maybe if an user try to say yes to the upgrade, mailspring will download and install the new version, but the launcher will continue to point to the old 1.9.x, if I well understood how the workaround works.

This can be a temporary solution, but if there isn’t yet an other builtin way to avoid new version auto check, it would be really useful to add such a feature.

Thanks again for your reply!

I am I’m favor of this suggestion, Mailspring 1.10.0 has shown the bad side of enforcing updates, and it should always be at the user’s preferences to choose if they want to update their instance or not.

2 Likes

+999999999999999999999999999 for disable automatic updates

to disable the update you can rename the updater so it doesnt run. however Im guessing your issue stems from the recent version, if you goto github their is a patch their from a member who has recompiled some binaries and it now works.

This just is not a good nor user-friendly operation, and this is what we’re looking for here. :slight_smile:

fix is now out, so I guess just use the official patch.

Still… There’s no way to disable updates…