Email service changed from IMAP to Google Suite. Mailspring won't recognize the new mapping


I have an email account that until recently was hosted on a dedicated server. I connected to it via Mailspring using IMAP.

This past week, we moved the mail server to a Google Suite environment, which broke the IMAP connection. I deleted the IMAP account from Mailspring, but when I try to reconnect using the Google Suite account set up, it fails at the very end. i.e. it succeeds in each step of setting up the new Google Suite-hosted email address, but get an error at the very end that says “Sorry, we had trouble logging you in. Authentication error - check your user name and password . (IMAP)”.

Here’s a screen grab of the error I’m getting:


Tried again this morning with the same result. Along the way, I get the following success screen, presumably pushed by Mailspring:

This is the screen I see when I’m finished with the Google Suite integration steps. Then when I get back to the Mailspring app, I see the screen I posted in the original message. Very frustrating.


Update: I uninstalled Mailspring and re-downloaded the app. When I tried to connect to my Gmail account (the one that used to be an IMAP account), it still fails with the “Authentication Error - Check your username and password. (IMAP)” message.

I’m a Mailspring Pro user, and have been happily using the software under my paid account. I’m wondering if this is the best way to get help on a tech issue for a Pro user.


This issue has been resolved, although I don’t quite understand how. I basically gave up, uninstalled the application (again – I had tried before to uninstall and recreate as an attempted solution with no success), tried Airmail, decided I hated it, decided to try Mailspring again, and this time it took my Google Suite account (formerly IMAP) without a problem.

So, thanks for the fix? Maybe? Would love to have this loop closed by the app providers if possible.