Get Mailspring Pro not working

Description

I’ve tried 4 times this morning to signup for mailspring pro - the first and third time, I just get a white box and nothing, the second time it asked for my credit card details and then went white and hung …

The fourth time, it accepted my card and said I was subscribed, and when I tried to download my invoice it asked me to login - I wasn’t aware that I had an account, so I said I wanted to change my password, but the box was bigger than the window it was in and I couldn’t cancel it.

When it took me back to the main window, my subscription has not updated. I tried the “reset my password” from id.getmailspring.com, it sent me the email, but the link just gave me a 504 error. I’ve tried deleting all cookies and it still does not work.

I quit & restarted Mailspring, and it still prompts me to upgrade and the subscription page says that Im not subscribed.

So now, I seem to have paid for the subscription which is not active and I have an account that I cannot use

To Reproduce…

Go to preferences → Account → Get Mailspring Pro

Screenshots

Setup

  • OS and Version: macOS 12.5.1
  • Installation Method: installer
  • Mailspring Version: 1.9.2

Additional Context