Gmail account keeps on disconnecting every time PC restarts

Problem

have 3 accounts connected (gmail & gsuite) but only 1 keeps having sync error. IMAP is also enabled in that account in gmail settings.

Context

After connection it works perfectly fine. But every time PC restarts or turned on the following day I always got this red error thing.

Email Provider

GMail

Setup

  • OS and Version: win10 home (19042.964)
    • Installation Method: installer
  • Mailspring Version: 1.9.1-30ef802f

This issue is becoming quite annoying.

3 Likes

Same for me, with a Gmail account.

1 Like

I have CONNECTION PROBLEM with HOTMAIL

Been waiting for a solution to this.

Same for me, i was one off the first to say that, never got a answer :frowning:

same here, logs:

13552 [2021-07-01 08:12:24.001] [main] [info] Identity created at 1584404126 - using ID Schema 1
13552 [2021-07-01 08:12:24.003] [main] [info] ------------- Starting Sync (douugbr@gmail.com) ---------------
13552 [2021-07-01 08:12:24.007] [metadata] [info] Metadata delta stream starting...
13552 [2021-07-01 08:12:27.017] [background] [info] Fetching XOAuth2 access token (gmail) for 8cf390db
13552 [2021-07-01 08:12:27.414] [background] [critical] 
***
*** Mailspring Sync 
*** An exception occurred during program execution: 
*** {"debuginfo":"https://www.googleapis.com/oauth2/v4/token RETURNED {\n  \"error\": \"invalid_grant\",\n  \"error_description\": \"Bad Request\"\n}","key":"Invalid Response Code: 400","retryable":false,"what":"Unknown exception"}
***

7448 [2021-07-01 08:12:28.433] [main] [info] Identity created at 1584404126 - using ID Schema 1
7448 [2021-07-01 08:12:28.435] [main] [info] ------------- Starting Sync (douugbr@gmail.com) ---------------
7448 [2021-07-01 08:12:28.441] [metadata] [info] Metadata delta stream starting...
7448 [2021-07-01 08:12:31.449] [background] [info] Fetching XOAuth2 access token (gmail) for 8cf390db
7448 [2021-07-01 08:12:31.818] [background] [critical] 
***
*** Mailspring Sync 
*** An exception occurred during program execution: 
*** {"debuginfo":"https://www.googleapis.com/oauth2/v4/token RETURNED {\n  \"error\": \"invalid_grant\",\n  \"error_description\": \"Bad Request\"\n}","key":"Invalid Response Code: 400","retryable":false,"what":"Unknown exception"}
***

11148 [2021-07-01 08:12:32.716] [main] [info] Identity created at 1584404126 - using ID Schema 1
11148 [2021-07-01 08:12:32.718] [main] [info] ------------- Starting Sync (douugbr@gmail.com) ---------------
11148 [2021-07-01 08:12:32.722] [metadata] [info] Metadata delta stream starting...
11148 [2021-07-01 08:12:35.723] [background] [info] Fetching XOAuth2 access token (gmail) for 8cf390db
11148 [2021-07-01 08:12:36.099] [background] [critical] 
***
*** Mailspring Sync 
*** An exception occurred during program execution: 
*** {"debuginfo":"https://www.googleapis.com/oauth2/v4/token RETURNED {\n  \"error\": \"invalid_grant\",\n  \"error_description\": \"Bad Request\"\n}","key":"Invalid Response Code: 400","retryable":false,"what":"Unknown exception"}
***

Also having the same problem.

Hey,

I can confirm that I experience the same issue, too.

Additionally, this issue does not seem to be verification-type related, as I have an account that uses IMAP and XOAuth2; and both are affected by this issue.

Finally, my desync happens very reliably:

  • at computer restart
  • after 5~8 hours
  • whenever I try to delete a draft message (100% desync).

Logs:
error_XOAuth2.txt (3.1 KB) error_IMAP.txt (3.0 KB)

Can confirm the same issues for outlook accounts. I had tried everything but the syncing still failed: reinstalling mailspring, remove the cached data and delete the entire appdata folder.

5 accounts, all Gmail, all using direct Gmail method (as opposed to IMAP). Most recently-added account needs re-authenticating/re-connecting every time I start Mailspring.

Same here but for me, all Gmail accounts are working ok, but one custom server account has the same problem people are talking about.

Mailspring Version: 1.9.1-30ef802f
Platform: win32
Account State: sync_error
Account Provider: imap
IMAP Server: imap.hostinger.es
SMTP Server: smtp.hostinger.es

36964 [2021-08-18 00:15:38.098] [background] [info] syncFolderChangesViaCondstore - INBOX.Sent: modseq 29 to 29, uidnext 264 to 264
36964 [2021-08-18 00:15:38.146] [background] [info] syncFolderChangesViaCondstore - INBOX.Drafts: modseq 3 to 3, uidnext 2 to 2
36964 [2021-08-18 00:15:38.193] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash: modseq 4 to 4, uidnext 3 to 3
36964 [2021-08-18 00:15:38.240] [background] [info] syncFolderChangesViaCondstore - INBOX.Junk: modseq 1 to 1, uidnext 106 to 106
36964 [2021-08-18 00:15:38.287] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash.Archives: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:15:38.334] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash.Archives.2019: modseq 2 to 2, uidnext 2 to 2
36964 [2021-08-18 00:15:38.381] [background] [info] syncFolderChangesViaCondstore - INBOX.Mailspring: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:15:38.429] [background] [info] syncFolderChangesViaCondstore - INBOX.Mailspring.Snoozed: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:15:38.429] [background] [info] Sync loop deleting unlinked messages with phase 1.
36964 [2021-08-18 00:15:38.429] [background] [info] Sync loop complete.
36964 [2021-08-18 00:16:38.997] [foreground] [info] Idle exited with code 0
36964 [2021-08-18 00:16:39.041] [foreground] [info] syncFolderChangesViaCondstore - INBOX: modseq 225 to 225, uidnext 1777 to 1777
36964 [2021-08-18 00:16:39.045] [foreground] [info] Idling on folder INBOX
36964 [2021-08-18 00:17:38.443] [background] [info] Syncing folder list…
36964 [2021-08-18 00:17:38.585] [background] [info] syncFolderChangesViaCondstore - INBOX: modseq 225 to 225, uidnext 1777 to 1777
36964 [2021-08-18 00:17:38.636] [background] [info] syncFolderChangesViaCondstore - INBOX.Sent: modseq 29 to 29, uidnext 264 to 264
36964 [2021-08-18 00:17:38.684] [background] [info] syncFolderChangesViaCondstore - INBOX.Drafts: modseq 3 to 3, uidnext 2 to 2
36964 [2021-08-18 00:17:38.738] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash: modseq 4 to 4, uidnext 3 to 3
36964 [2021-08-18 00:17:38.785] [background] [info] syncFolderChangesViaCondstore - INBOX.Junk: modseq 1 to 1, uidnext 106 to 106
36964 [2021-08-18 00:17:38.832] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash.Archives: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:17:38.879] [background] [info] syncFolderChangesViaCondstore - INBOX.Trash.Archives.2019: modseq 2 to 2, uidnext 2 to 2
36964 [2021-08-18 00:17:38.926] [background] [info] syncFolderChangesViaCondstore - INBOX.Mailspring: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:17:38.973] [background] [info] syncFolderChangesViaCondstore - INBOX.Mailspring.Snoozed: modseq 1 to 1, uidnext 1 to 1
36964 [2021-08-18 00:17:38.973] [background] [info] Sync loop deleting unlinked messages with phase 2.
36964 [2021-08-18 00:17:38.973] [background] [info] Sync loop complete.

This issue is allmost overkilling for me, still no fix for this?

Same issue here using gmail.

1 Like

Same here. 4 accounts : 2 IMAP with no problem.
1 gmail > need to reconnect each time PC restart
1 hotmail > need to reconnect each time PC restart

I have this problem too… with 3 gmail/gsuite accounts. Everytime my computer restarts I have to reconnect all 3 accounts.

Same problem here, has anyone been able to find a fix?