Hotmail | SMTP Connection Error Code 25 | Unable to connect to the server / port you provided


Whenever I try to authenticate Hotmail with MailSpring. I get this error: Unable to connect to the server / port you provided. (SMTP).


I’m using MailSpring for about a year now. From about a month I noticed that the emails aren’t send no matter what and I have to log in the browser to sent it. I downloaded the latest version and used the source of the version that I had on the laptop and nothing seem to work.

I also tried authenticaling manually using the IMAP and SMTP settings provided in Hotmail. It’s not working either.

This is part of the log file.

connect 587
mailsmtp Last Error Code: 25
mailsmtp Last Error Explanation: MAILSMTP_ERROR_CONNECTION_REFUSED
mailsmtp Last Error Location: 1
mailsmtp Last Auth Type: 0

Email Provider

Hotmail. But also I have the same problem for my Gmail accounts.


  • OS and Version: Windows 10
  • Installation Method: I don’t know what this is.
  • Mailspring Version: 1.9.1-30ef802f

Hey folks! I’m extremely happy … after hours of troubleshooting and reading a lot of forms.
I managed to fix the Gmail sync issue. Here are the steps:

  1. Use this link to enable IMAP in your Gmail account.
  2. Use the IMAP/SMTP authentication in MailSpring [the Gmail authentication didn’t work for me after Step 01]
  3. Use the configuration of IMAP/SMTP in the previous link.
  4. The trick here is to generate an app password from Gmail if you’re using 2-factor authentication. Use this link to help you.

It is good here to mention that I followed the same steps for my Hotmail accounts [getting the Hotmail configuration and using an app password]… but that didn’t work for me.

Also, my faculty Gamil account doesn’t have a generate password feature [this account doesn’t have a 2-factor authentication option] … I’m still stuck at authenticating it [the Log file says ‘Invalid Credentials’ … the normal password isn’t working!].

Ok … I managed – with great turnabouts to authenticate my G-Suite email …

  1. Turn on the ‘Less Secure App Access’ in the Security tab in your Gmail account.
  2. Open an incignito tab if you’re using more than one google account.
  3. Use this link and under the TroubleShooting Steps, click on the Display Unlock Captcha …
  4. The usual MailSpring’s Gmail authentication didn’t work for me. But the IMAP/SMTP authentication worked [with the configuration provided by Gmail].

Note that foe the G-Suite, the main problem was the unability to provide an App Password [the True credentials weren’t accepted at first. But after these steps, it was accepted]