I can't uncheck "run on startup"


I go to settings
I uncheck “Run on startup” or, in my language “Starten beim Systemstart”
I exit the settings
I go back
It is checked again

To Reproduce…

Go to settings
Uncheck “Run on startup”
Exit settings
Go back

Expected Behavior

The option should stay turned off after i turned it off


Windows 10 19042.685
Mailspring 1.8.0

Additional Context

The setting in of itself seems to be working. It removes and adds a shortcut to Mailspring in shell:startup.
It appears to be just a UI bug then

I can confirm on Ubuntu 20.04 and Mailspring 1.8.0.

Should be a relatively easy fix.

Duplicate Issues:

I’ve taken a shot at fixing this: Make "Run on Startup" UI state persistent · Issue #2265 · Foundry376/Mailspring · GitHub