I'm deleting Mailspring from all our Linux machines: JSON crash + terrible syncing

Mailspring version 1.9.2 installed on several machines running ZorinOS 16 (Ubuntu Linux 20.04 LTS). I have tried uninstalling & then reinstalling Mailspring multiple times to try to resolve the error behavior. I have also tried installing both the snap package and the flatpack – no difference.

The problem(s):

  1. When left unattended, i.e., running in the background (as intended/designed), after a random period of time, Mailspring invariably crashes and throws up a JSON sync error. This might be somewhat tolerable if all that was required was to close Mailspring and restart it, but, no, that’s not possible because (a) Mailspring doesn’t want to close and won’t respond to a “force quit” command", and (b) when it crashes, the JSON error disables the entire system – you cannot restart your computer, log out, nor shut down (indeed those buttons are grayed out (nonfunctional), so only alternative is to power off the machine.

It appears that the Mailspring JSON crash also compromises Firefox because often, but not always, the JSON error message coincides with Firefox spontaneously crashing – oh, and BTW, when this happens Firefox cannot be restarted so, again, only option is power down the computer.

Really, the only way to avoid this behavior is to leave Mailspring open for only short periods of time. Closing & then reopening it as needed, which really defeats the purpose of installing an e-mail app which is supposed to be capable of syncing in the background. Yeah, but of course, that assumes that Mailspring is capable of reliably syncing in the background . . .NOT!

Problem 2: Syncing is extremely unpredictable, sometimes occurring as designed, but more often than not it just doesn’t sync or is HOURS behind. And closing/rstarting Mailspring doesn’t fix the problem – it still won’t update the Inbox. What will cause Mailspring to update the Inbox? Well, restarting the computer, of course!

As it currently performs, Mailspring is unusable on our Linux machines. It does seem to be more stable on Windows (dual boot), but even there syncing is frequently sluggish. But since we’ve migrated nearly all our machines to Linux, we cannot continue using Mailspring until/unless these fatal deficiencies are resolved.

I’m quite disappointed in having to make this decision, as Mailspring has far & away the best UI, configuration options and feature set of almost any e-mail program available (with exception of Bandcamp HEY!), but the price of using Mailspring on Linux is having to power down & reboot our computers multiple times per day . . . and that is not going to work.

Correction / clarification: the problem is a JSON.CFG (config) error, though it appears to be sync related. I tried one last time uninstalling & reinstalling Mailspring, this time setting up Gmail (because some reports have reported that Mailspring struggles with syncing Yahoo accounts). But, two hours later another JSON.CFG crashed the computer forcing a complete power down. Done, done, done.