Image upload for signature no longer works

After setting up a new copy of Mailspring on MacOS I can no longer add an image to my signature. I receive the following error.

Sorry, we couldn’t save your signature image to Mailspring’s servers. Please try again.

(Error: POST returned 500 Internal Server Error)

I tried on three different computer running Mojave, Big Sur and Monterey. I then thought it could be the latest version of Mailspring but the past two versions and no luck. Only my laptop, that already had Mailspring installed with a signature image, is working properly.

What am I doing wrong?


To Reproduce…

Steps to reproduce the behavior:

Expected Behavior



  • OS and Version:
    • Installation Method:
  • Mailspring Version:

Additional Context

I see the issue on Ubuntu as well, but it will take a PNG no larger than 64px by 64px in size. I suspect there’s a size limit but the servers aren’t responding with the correct response.

It seems like a hickup with the server. Does this still happen with you? I, unfortunately cannot reproduce it.

Today, I tried it again with a 64 pixel square PNG image. The server threw a 504 and a 500. Then it worked a third time.

In my case, I get the error with a specific png.

When I try with my old signature image it works, and I don’t get the error message.
I am on a macos with Big Sur

Still have it to this day with whatever one I use.