Mailspring was unable to create or delete the LaunchAgent file

Description

When I try to disable “Launch on system start”, I get this error:

Screen Shot 2020-05-02 at 9 50 17 AM

I wanted to use the “Login Items” feature of macOS so I could hide Mailspring on start, which doesn’t seem achievable just using the “Launch on system start” feature in Mailspring.

To Reproduce…

Steps to reproduce the behavior:

  1. Go to Preferences
  2. Try to untick “Launch on system start”

Error above received.

Expected Behavior

I expected no error to appear and for the box to get unticked.

Screenshots

Setup

  • OS and Version: macOS 10.14.6
  • Mailspring Version: 1.7.6

Additional Context

I only recently installed Mailspring.


(Originally psoted by squintgit on GitHub.)

Hey thanks for reporting this! I’ll see if I can reproduce this - I wonder if something changed in macOS 10.14.


(Originally posted by bengotow on GitHub.)

I just installed Mailspring (through Homebrew) and am seeing the exact same error message on Catalina 10.15.6.


(Originally posted by RavHilton on GitHub.)

Same On High Sierra 10.13.6

Mailspring was unable to create or delete the LaunchAgent file at /Users/designlab/Library/LaunchAgents/com.mailspring.plist.

Error: ENOENT: no such file or directory, open ‘/Users/designlab/Library/LaunchAgents/com.mailspring.plist’

came wile swishing to debug flags


(Originally posted by designlabmx on GitHub.)

I get the same message after installing via homebrew brew install --cask mailspring

Screenshot 2021-02-19 at 09 25 16


(Originally posted by cabbage on GitHub.)

I’m getting the same pop up window. Running OS Cat 10.15.7, Mailspring 1.8.0.

I’m getting the same error on a fresh install Mojave 10.14.6.