Mailspring will no longer open


Not sure why, but I can no longer open Mailspring. It just never launches. I also couldn’t install from the .deb file from the website.

To Reproduce…

Steps to reproduce the behavior:

  1. Open Mailspring as usual
  2. Doesn’t work

Expected Behavior

I expected the app to open and let me view my emails.


  • OS and Version: Pop OS 20.10
  • Mailspring Version: Everything is up to date (according to snap), but I can’t see the exact version because I can’t open the menu

Additional Context

This is what I get when I try to launch Mailspring from the terminal:
/snap/mailspring/488/bin/desktop-launch: line 51: /home/user/.config/user-dirs.dirs: Permission denied
Gtk-Message: Failed to load module “appmenu-gtk-module”

I also tried (sudo apt-get install appmenu-gtk2-module appmenu-gtk3-module) and everything there is also up to date.

Non of my googling was effective or showed me anything that actually helped.

(Originally posted by Mycheze on GitHub.)

I think that your problem has nothing to do with the Gtk message you see. Many of us also see that message and there’s no problem. The real problem is that you can’t access your configuration directory.
Because you installed Mailspring using a snap package, the permission of that package might be wrong, or you need to install Mailspring using the --classic flag (which might not helped).

I think your best bet would be to install Mailspring using the .deb file rather than snap. Nonetheless, this bug should be looked at, especially if other people are having the same problem.

(Originally posted by fcastilloec on GitHub.)

I didn’t think the Gtk thing was an issue, but I decided to include it anyway.

Using --classic didn’t seem to do anything either.

I already tried to use the .deb file, but it said the “Installation Failed” (The following packages have unmet dependencies:
mailspring: Depends: gvfs-bin but it is not installable).

I tried googling those issues too but didn’t find anything useful.

Should I maybe purge the snap version or something?

(Originally posted by Mycheze on GitHub.)

It seems you’re out of luck this time. If there’s a dependency problem, it means the .deb file won’t do it. I see that a PR was merged that will solve the .deb issue (see here)
Hopefully, in time, a new version will be released that you’ll be able to use.

1 Like

A new release is underway for hopeful release this week, and that fix is included. Stay tuned!

1 Like

¡Hey There!
I have same behavior but i have no idea where to get the logs for tracking the problem.
I have Debian 10 with Mailspring 1.8 installed and working, but when upgrading to 1.9 appears NOTHING.
When installing, dependencies appears but doing ‘apt-get -f install’ it gets installed without warnings or errors.

When launching, there’s no signal of mailspring starting even watching htop process filtered.

I’ve deleted every mailspring folder that i can found, even settings folders.

Thanks for eventual response.

Hi There!

Luckily, tried launching mailspring with TERMINAL and got some hints:

[6190:0424/] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /usr/share/mailspring/chrome-sandbox is owned by root and has mode 4755.
`trap' para punto de parada/seguimiento

So, did these changes (changing owner and mode) and mailspring launch with no errors.

Thanks for your help guys…