Mailspring won't open after update 1.10.0


Got a notification in Mailspring saying there is an update available, and after installing it I can never open Mailspring again. I even reinstalled and deleted everything related to Mailspring and still the same issue

To Reproduce…

Steps to reproduce the behavior:

  1. Install version 1.10.0
  2. profit ?

Expected Behavior

For Mailspring to open


For some reason the word “Mail” will have random characters, mostly Chinese ones (and my pc is not chinese)

Pressing okay will open the same error again


  • OS and Version: Windows 10
  • Installation Method: MailspringSetup.exe from GitHub
  • Mailspring Version: 1.10.0

same behaviour here when updating to 1.10


This broke the entire app. Pure evil suggesting an update and then completely breaking itself.


same here :frowning: completely broken after update

I’ve returned back to 1.9.1
you can download exe or dmg from here


Same error just 1hour ago…
This rollback worked for me!! Thanks @RonBilevich

Setup :
OS : Windows 11
Update method : popup on bottom corner
Error app version : Mailspring Version 1.10.00

1 Like

Same for me. I also rolled back to version 1.9.2 and it now works for me

1 Like

Hello everyone, please see my post at Database Error and unable to launch app after installing V1.10.0 - #11 by Predeactor to rollback to the version before the update.
It worked perfectly for many users!


Quick restore of the older version:
winget install --force mailspring --version 1.9.2

1 Like

Thanks a lot, that’s really convenient., especially as mailspring updates itself to the broken version.
When will a fix be deployed so we can safely continue to upgrade?

1 Like

Sadly, there’s no answer yet, so you can take this one which is from me: When it’s there. :slight_smile: Just being amusing, but that’s really it…

1 Like