Database Error and unable to launch app after installing V1.10.0

Same here. I love mailspring but between the constant reconnecting mailboxes and reinstalling updating fails this is hardly a solution, Not ungrateful just annoyed since now every morning i have to uninstall… Reinstall. reconnect 4 mailboxes before actual mail. It takes the “spring” out of mailspring

1 Like

I have the same issue, it’s driving me nuts? Any solution people please ?

I have the same problem :frowning:
I can not download 1.9.2 version. Put this version somewhere please!

Same issue here. On version 1.10.0 (upgraded into it) on Windows 10.
Manually launching Mailspring\app-1.9.2\mailspring.exe works as a workaround.


Do You have version 1.9.2 ?

Hello everyone.
As I’ve ran into the issue myself, I also find a better workaround, following @dgiakoum’s advice, so all thank to him.
This method will not erase your data, settings, themes, etc… so you’re safe to read this guide.
I would also like to mention that the developers of Mailspring are working ASAP on the issue, hopefully a hotfix will arrive soon!

Killing Mailspring Instance

First of all, it is important to “kill” Mailspring, because it is probably running in the background, as such, please do this first:

  1. Open the task manager by doing Ctrl+Shift+Esc (Or Ctrl+Shift+Del → Task manager)
  2. You should see a simular windows, if not, click on Name at the top:
  3. Click on Mailspring
  4. Click on End task at the bottom right.

You can now close the task manager and go on.

Uninstalling 1.10.0

  1. Go to %LocalAppData%\Mailspring (Windows+R)
  2. Delete the folder app-1.10.0

We’re not exactly done yet…

Suspending updates

Until the developers push an update, we need to block the update, because it will automatically install at every exit, reload, etc…

  1. Go to %LocalAppData%\Mailspring (Windows+R)
  2. Rename Update.exe to Update.exe.old

Congratulation, you just saved your Mailspring instance!

This is how I fixed the Mailspring’s 1.10.0 issue, I cannot tell if this will work for you, many peoples were helped by my guide, many were not, as such, if you are unable to rollback your Mailspring instance to 1.9, consider reinstalling Mailspring entirely, I’ve made another post about this, you can read this here:

I suggest to rename Update.exe.old back to Update.exe when the developers of Mailspring will fix the issue.

I hope this solution will work for you, if not, I hope my second post will, and, if not, keep fingers crossed and hopefully, a hotfix will arrive soon!
:slight_smile: Have a good day


If you visit their repository page on github you will find all their previous releases here: Releases

Here a shortcut to release page of V 1.9.2 with all installers: V1.9.2

1 Like

Nice. Very straightforward to avoid reinstallation.

1 Like

My app automatically installed the 1.10.0 update this morning. Tried this workaround and it worked fine – reinstallation avoided.

1 Like

This worked for me! Thank you.
If it tells you that folder is used by another process, you need to shut down mailspring from task manager

1 Like

no, both deleting the folder and uninstalling doesn’t work for me. The app is totally fucked up on my Windows 11 now. I don’t see how an update can make this happen.

1 Like

I freported this too, then realized that I actually had TWO errors, and forgot to screenshot the first (which marked better_sql3.node as “not a Win32 application”). This error went away, but the broken DB stood.

And this is where I am now. You know, I am trying to apply for a job - kinda hard without an email client… ^^;
Going to try and install something before 1.10… x.x

The minute I saw this message… I knew I shouldn’t click the “Install” button but it’s just too tempting for me. Being a returning user after a couple of years, I knew from the past that Mailspring’s updates are risky. Half the time, it breaks everything. I even checked the release notes before and I saw the big jump (and I said “Not looking good…” in my head – especially with the Electron stuff) but I tried nonetheless…


Of course, everything was broken after the update. Deleting the folder did the trick, THANK YOU.


For those “fixing” the problem by deleting the folder app-1.10.0 - check to see what version you’re actually using. I think deleting that folder actually deletes the update and you’re back to the previous version. Deleting the folder did not help me. I can only use version 1.9.2.

Hi there, my version of Mailspring is apparently 1.9.2 too, as such I think that 1.9.2 is the actual “stable” version of Mailspring
As you can see, this is my version:
I personally think that yes, it delete the update, and make you go back to the previous version, but if it does not help you, I’m out of luck here, and you’ll be on your own :confused: All I can suggest is a complete uninstall + reinstall…
This is my solution after all, worked for me, can’t work for everyone, after all, it’s a temporary solution until a new update comes out, hopefully!

Edit: Now thinking about it, it also could be something regarding the cache in %AppData%/Mailspring, but I would disregard this opinion, I would prefer to not touch this folder because it contain settings/config, everything you have set, etc…

You can check your version under the three line menu in the upper-right part of the Mailspring app. I just hesitate calling it a “solution” since you’re just reverting to the previous build–not actually fixing the bug. That’s what I had to do, uninstall and reinstall. I didn’t lose my preferences or account settings, however, which was cool. :slightly_smiling_face:

Having the same issue - cannot go back to 1.9.2 and I deleted anything having to do with Mailspring. It won’t let me start fresh and I continue to get the error message “We encountered a problem with your local email database. We will now attempt to rebuild it.” and nothing happens. So frustrating, especially for something you pay for!!!

Well that’s temporary, there’s no real official answer so far and we must wait for a hotfix, hopefully soon, in the meantime, we’re just finding alternatives to rollback to a latest working version!
The point of my action was to make everyone sure to not erase any settings… So, yeah… :stuck_out_tongue:

Hi there,
Have you tried my solution, if not, try it, this probably could work!

If not, you can check my other post on how to make a complete reinstall without losing your data: