Mailspring won't sync after install of V1.90 for Windows 11


after upgrading to version for Windows 11, I get the error “Encountered an error while syncing”

I went to the Mailspring webpage to research the problem and noticed the release of a newer version V1.91 so I downloaded it and tried installing that to no avail. Still had the issue.
I realized I had not installed the application as Admin so I closed the app and tried reverting back to the 1.90 version and installing as admin and then ran V1.91 as admin as well but no change.

After running V1.91 installation as Admin, I now get "Cannot authenticate with with the choice of Check again and Reconnect. When I click Reconnect is when I get the message “Sign in with Google in your browser” and “Page didn’t open? Paste this URL into your browser” with a very long link in it. When I copy that link and try going there I get the message

Access blocked: Authorization Error
The OAuth client was deleted.
If you are a developer of this app, see error details.
Error 401: deleted_client


Will not download email since reboot.

Email Provider

I use Gmail for the provider
I found this information with Google that indicates the problem.

If you get an error that starts with “401,” that usually means the developer didn’t properly register their app with Google.

To help protect your account, before a third-party developer can use Sign in with Google, Google asks them to register their apps. We don’t share your info with the developer until they register with us. Some of the error messages you might get include:

  • 401 invalid_client: Either the app doesn’t match the info on its registration or the developers haven’t given Google all the required info.
  • 401 deleted_client: The app or service isn’t registered with Google anymore.

What can you do about this error?

Only the third-party developer can fix this issue. Contact the developer directly to tell them about the error.


  • OS and Version:
    |Edition|Windows 11 Home|
    |Installed on|‎6/‎19/‎2023|
    |OS build|22621.3155|
    |Experience|Windows Feature Experience Pack 1000.22684.1000.0|

    • Installation Method:
  • Mailspring Version:
    Windows 11 version of Mailspring V1.90 and then V1.91

I have now reset cache, reset accounts and settings, uninstalled Mailspring, rebooted the PC and it still locks me out with the 401 error

Finally fixed it by downloading the latest file from Mailspring site, uninstalling and running the install as admin.

All fixed.