Moody search - Periodi

Mailspring Version 1.9.2 (1.9.2)
MacOS Catalina 10.15.7 (latest update)

I came across a funky bug when searching for an email. I wanted to delete all test e-mails containing the word “Periodic …” in the subject.
So I typed in “periodi” and hit enter nothing found. I typed in “Perdiodi” nothing there. I tried “periodic” - all mails found containing that word. I tried “period” - all mails found.
As soon as I type in “periodi” - nothing found.
What’s goin on?

I rebuilt the cache of that inbox, did not change the behavior.

Any ideas?


yeah same here but I can’t even get results if I try to be more complete, i.e:
Mailspring search results for “aurora”:

Web-based email client for my uni mail:

It doesn’t show the 2 emails which I answered (the ones that have Re. at the start) idk but this doesn’t happen with apple mail in my MB for example.

if you can not find those emails at all, than it might be something else. In my case, it looks like it depends on the length of the search term.

period - finds emails
periodic - finds emails
periodi - does not find those emails