Moving messages from email folders like "Sent"

For more than a decade I’m using Thunderbird, but I’m pretty used to the way it works, and Mailspring has a pretty dope interface, and I’m trying to understand if is a good replacement.

But one of the things I do, and a lot of colleagues of mine also do is group all the emails from one subject into one folder, event the sent ones.

I tried in a few different ways, and I’m not able to move email messages from Sent folder or Trash folder to the inbox, or for example to another folder created by me. Simply nothing happens and no feedback from the app is given.

I’m using an IMAP/SMTP account.

The only time I’ve seen Mailspring refuse to move messages is when I try to do it from one account to another - annoyingly, it will only move messages within an account (and doesn’t even provide visual feedback when you try to drop a message onto a folder it won’t do anything with). Are you trying to move messages to folders within the same account?

Also, you should be aware that Mailspring always moves entire threads to the destination, including your received and sent messages. Again, this is very annoying because the Sent folder is effectively useless (and inconsistent if you use different mail clients on the same account) but seems to be something we’re stuck with.

It would probably help if you shared your operating system and version, and Mailspring version and installation method, because there are some differences.

OS: Windows 11
Mailsprint: 1.9.2-6e14dad1
Installation method: Download the exe from the website and did a simple installation.

I’m trying to move messages in the same account to a custom folder, simply as that. The cursor icon change to warn me I’m moving a message, but when I drop it in any folder nothing happens.

Hmm. Have you tried using the Move button on the toolbar (usually looks like a folder with an arrow in, in the toolbar over the message viewer)? Or the Move keyboard shortcut (which will vary depending on how you set up your shortcuts - for me, it’s Ctrl-M)?

I know other issues have been reported with Windows 11 but I don’t think I’ve seen this one come up before I’m afraid.

I didn’t realize there was a button to move (but yeah makes sense for touch environment).
It worked :open_mouth:

So, should I report this as a bug? Or should I mention someone to overlook this?

What is also strange is, drag and drop from inbox to another folder is ok, but drag and drop from sent folder doesn’t work.

Ah, now, I can replicate the “can’t drag to move” from the Sent folder, but only that folder. Sorry, I hadn’t spotted that was the specific folder you were having problems with!

The toolbar isn’t just for touch - lots of apps have toolbars - but, yeah, there are (at least!) three different ways to move a message in Mailspring (drag, toolbar, keyboard).