Office 365 connection error


Can’t connect to Office365 mail account


to reproduce:

  1. new account > Office 365
  2. get redirected to browser for authentication and get following error:

OAuth Code exchange returned 400 Bad Request: {“error”:“invalid_request”,“error_description”:“AADSTS9002327: Tokens issued for the ‘Single-Page Application’ client-type may only be redeemed via cross-origin requests.\r\nTrace ID: 8d750c62-95bb-4794-90f4-132dbf624800\r\nCorrelation ID: 104b1759-d3c5-4d4f-9b3e-99420831fef6\r\nTimestamp: 2022-03-30 07:45:19Z”,“error_codes”:[9002327],“timestamp”:“2022-03-30 07:45:19Z”,“trace_id”:“8d750c62-95bb-4794-90f4-132dbf624800”,“correlation_id”:“104b1759-d3c5-4d4f-9b3e-99420831fef6”}

This issue occured after upgrading to 1.10.x
Issue is not present in Mailspring 1.9.2-6e14dad1

Email Provider

Microsoft Office 365


openSUSE Tumbleweed 20220324
Installation Method: .rpm
Mailspring Version: 1.10.2-69a03d6d

inxi -b
Host: latituder Kernel: 5.16.15-1-default x86_64 bits: 64
Desktop: GNOME 42.0 Distro: openSUSE Tumbleweed 20220324
Type: Laptop System: Dell product: Latitude 7280 v: N/A
Info: Dual Core Intel Core i5-7300U
Device-1: Intel HD Graphics 620 driver: i915 v: kernel
Display: wayland server: driver: loaded: modesetting
unloaded: fbdev,vesa resolution: <missing: xdpyinfo>
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 22.0.0
Device-1: Intel Ethernet I219-LM driver: e1000e
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
Device-3: Intel Bluetooth wireless interface type: USB driver: btusb
Local Storage: total: 476.94 GiB used: 82.02 GiB (17.2%)
Processes: 262 Uptime: 18h 45m Memory: 15.5 GiB used: 3.76 GiB (24.3%)
Shell: Bash inxi: 3.3.07

Thank you very much

Same issue here, running on Manjaro Linux. This issue is present since 1.10.0 for me, so I downgraded back to 1.9.2 (last working version). As I had seen someone else reporting this, with the recent release of 1.10.2 I decided to try again an upgrade today to see if issue had been addressed, but again same issue is present, so downgraded once again, and added mailspring to AUR updates ignore list :confused:

1 Like

Same here… and Office 365 integration never worked for my account in any version I tried. Hopefully, the team will solve it at some point.

I have practically the same issue on rocky linuc.

A year ago i dident have this problem on windows

OAuth Code exchange returned 400 Bad Request: {"error":"invalid_request","error_description":"AADSTS9002327: Tokens issued for the 'Single-Page Application' client-type may only be redeemed via cross-origin requests.\r\nTrace ID: 14573c3a-8004-4013-9308-15783b2e3700\r\nCorrelation ID: 2db7cf27-6d46-42bd-9582-bbd6bb46fd75\r\nTimestamp: 2022-04-05 17:00:02Z","error_codes":[9002327],"timestamp":"2022-04-05 17:00:02Z","trace_id":"14573c3a-8004-4013-9308-15783b2e3700","correlation_id":"2db7cf27-6d46-42bd-9582-bbd6bb46fd75"}

1 Like

Issue seems to be gone in 1.10.3
thank you!
I would close the ticket but don’t know how/if it is even possible