Password Management Error

Another reason could be that the electron version shipped with Mailspring does not yet contain the bindings for kwallet6. In that case you could try to Ensure that kwallet5 is installed an force it’s usage with the corresponding flag in the desktop file.

I am currently traveling, but will try to figure out a solution when I am back.

1 Like

I finally found a solution with KDE 6 that solved the problem for me.

  1. In the Application Launcher, search for Mailspring.
  2. Right click on it and select “Edit Application…”
  3. Navigate to the “Application” tab.
  4. Update the “Arguments” field to read '--password-store=gnome-libsecret %U'
  5. Click “OK” at the bottom and close the menu.

Hope this helps anyone else encountering this issue in KDE 6.

2 Likes

Thanks, mate. This worked good in Arch Linux KDE Plasma 6 and have been able to setup my Mailspring accounts at last.

Unfortunately no success here: Tumbleweed KDE 20240329, KDE Plasma 6.0.3, KDE Framework 6.0.0, QT: 6.6.3, Kernel 6.8.1, Graphics: Wayland
But thanks anyway :slight_smile: