Pro Subscription Not Registering, Can't Login


I purchased a pro subscription, but was forced to go through the website directly, as the Win 11 app repeatedly failed to bring up the page.

After closing and opening the app and forcing a sync for my Mailspring account, the app still did not register my pro subscription. I therefore logged out of my Mailspring ID in the app. I have now attempted to log in again and am repeatedly given an error screen I can do nothing about (see image)

To Reproduce…

Steps to reproduce the behavior:

  1. Go to ‘Settings’
  2. Click on ‘Subscription’
  3. Select ‘Setup Mailspring ID’
  4. See error

Expected Behavior

Login to Mailspring ID in Win 11 app.
Have Pro and all Pro Perks applied to said app.



OS and Version: Windows 11 Home Version 22621.2861
Installation Method: Installer from Mailspring website
Mailspring Version: 1.13.3-9a7e1a78

Additional Context

It seems to have no difficulty pulling my email (even after the uninstall and reinstall despite trying to clear out all associated files), but can neither connect to the Mailspring ID check nor even updates.

Are you in a corporate network, use some kind of web proxy or have something else in your network that should block the access to the marketing servers? It seems like the Mailspring client can’t connect to the Mailspring server properly.

This is a home PC on a basic router supplied by the ISP. As far as I know there is no proxy setup by them, and I certainly haven’t. :confused:

That having been said, I just went back to double check and it magically works now, so… there’s that. -_-

Thanks for the suggestion, though.

Glad to hear it works now. Maybe just a temporary Internet connection issue.