Signature Image Issue on Linux

I’ve been trying today to set my signature image, but I’ve been met with this error each time I attempt to upload the chosen .png . Before today, the image worked just fine. Today, no dice. I just purchased a premium subscription, so I thought this issue would be a worthwhile post for tech support.

I am using MailSpring on Elementary OS 6.1.

Thanks very much for your time and help, and thanks for a great product as well!

Hi @cmul1611,

I am sorry to hear that. Can you please try to do the following:

  • Delete the e-mail signature completely
  • Create a new signature with the image

Does this work? Does this upload work with another image?

@Phylu , thanks for your time! I just tried that, but I was met with the same error message.


Appreciate your help!

@Phylu , think I found a work around with remote images and raw html. :+1: Thanks for your time in trying to help me!

@cmul1611 Glad to hear. Thanks for the information. :slight_smile:

Same issue over here. I 'm working on Linux Mint.
I tried to log off and on again to my Mailspring ID account, deleting the whole signature and so, but the problem remains.
Any ideas? I’ve no clue the solution @cmul1611 posted about and I’m afraid I’m not linux nerd enough to dive deeper than ‘noobie level’

I have the same problem for uploading image into the signature. System - Ubuntu 20.04, version of program - 1.10.3 (Pro version)


POST /api/save-public-asset HTTP/1.1
Connection: keep-alive
Content-Length: 25675
accept: application/json
authorization: Basic ZjM1YzBmMGMtMDk0MS00YjRmLWExMzAtNmE1YWIzN2UxMTIyOg==
User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Mailspring/1.10.3 Chrome/98.0.4758.141 Electron/17.4.0 Safari/537.36
Content-Type: multipart/form-data; boundary=----WebKitFormBoundaryh8ZKSSkDtjQ6alei
Sec-Fetch-Site: cross-site
Sec-Fetch-Mode: cors
Sec-Fetch-Dest: empty
Accept-Encoding: gzip, deflate, br
Accept-Language: ru

HTTP/1.1 500 Internal Server Error
Connection: keep-alive
Content-Length: 579
Content-Type: text/html
Date: Fri, 08 Jul 2022 13:17:12 GMT
Server: nginx/1.20.0
Content-Security-Policy: default-src * mailspring:; script-src 'self' 'unsafe-inline' chrome-extension://react-developer-tools; style-src * 'unsafe-inline' mailspring:; img-src * data: mailspring: file:;