SMTP Relay Rejection Error - Help Needed

Hello Support Team,

I’m encountering a recurring issue with the GetMailspring application related to SMTP relay rejection, and I would appreciate your assistance in resolving this matter.

Error Details:

Error Code: SMTP-550
Description: SMTP Relay Rejection

Issue Description:

I’m currently experiencing difficulties when attempting to send emails through the GetMailspring client. Each time I try to send an email, I receive the aforementioned SMTP-550 error.

Here are the specific details of my configuration and the steps I’ve already taken to troubleshoot:

  1. SMTP Server Settings:

SMTP Server:
Port: 587 (I’ve also tried port 465 with SSL/TLS)
Authentication: Yes (using the same credentials as my incoming mail server)
Encryption: STARTTLS (I’ve also tried SSL/TLS without success)

  1. Email Provider:

Provider: MyEmailProvider
Account Type: IMAP

  1. Troubleshooting Steps Taken:

Verified Credentials: I have double-checked my username and password, ensuring that they are correct and match my incoming mail server credentials.

Checked IP Blacklisting: I verified that my IP address is not blacklisted using multiple IP blacklist check tools.

Reviewed SMTP Settings: I cross-checked my SMTP settings with the recommended configuration provided by my email service provider.

Network Configuration: Ensured that there are no firewall or network restrictions that could be blocking SMTP traffic.

Tested with Other Clients: I attempted to send emails using a different email client (e.g., Thunderbird), and it worked without any issues, indicating that the problem is specific to GetMailspring.

As per this article I came across- Salesforce Marketing Cloud Journey Builder, the SMTP server rejected the email relay request. This might occur if the server is configured to deny relaying for certain users or IP addresses. Check your SMTP server settings, ensure you have the correct permissions, and verify that your IP address is not blacklisted. Contact your email administrator for further assistance.

As I have mentioned above, I already check the SMTP server settings, and it’s upto the mark as per me. I also tried the solution in this thread SMTP server would not relay a message but it didn’t work.

Kindly provide the solution.