Unable to launch the app on Fedora 35


I have a fresh Fedora 35 installation, running Gnome 41.1 on Xorg with the latest Nvidia driver. I installed Mailspring from the rpm file downloaded from the download page. The installation was successful but the app wouldn’t start.

To Reproduce…

Steps to reproduce the behavior:

  1. Download the rpm installer from the download page
  2. Install the app on Fedora 35
  3. Try to start the app (either from GUI or command line)

Expected Behavior

The app should start.



  • OS and Version: Fedora 35
    • Installation Method: rpm
  • Mailspring Version: 1.9.2-6e14dad1

Additional Context

Are you using Wayland as Window Manager? There seems to be an issue with that configuration. You may try the flatpack version, as somebody suggested here: https://github.com/Foundry376/Mailspring/issues/2352#issuecomment-963595992

As I mentioned, I am running Xorg with the latest Nvidia driver. So no, I am not using Wayland.

Yes, I turned to the flatpak version as a workaround, but it’d be great if this issue gets some attention and gets resolved. If there’s anything that I can provide to help (logs, tests, etc.), I’d be happy to do so.

I experienced a similar issue after upgrading from Fedora 34 to Fedora 35. When running from the console the following output is generated

(electron) The default value of app.allowRendererProcessReuse is deprecated, it is currently “false”. It will change to be “true” in Electron 9. For more information please check https://github.com/electron/electron/issues/18397
[153046:1215/141922.056700:FATAL:gpu_data_manager_impl_private.cc(1034)] The display compositor is frequently crashing. Goodbye.
Failed to get crash dump id.
Report Id: {“success”:true}
Failed to get crash dump id.
Report Id: {“success”:true}
Illegal instruction (core dumped)

Actually, it seems to be more of an Electron problem with the new Nvidia driver and should be solved by an upgrade of Electron that I believe is in progress.
As a temporary workaround suggested by someone here in the Etcher repo, one can add --disable-gpu-sandbox after mailspring. For Fedora user, that would probably be updating /usr/share/applications/Mailspring.desktop by changing Exec=mailspring %U to Exec=mailspring --disable-gpu-sandbox %U. It works for Mailspring and a couple more Electron apps where I encountered similar problems. Now I can use the “native” rpm version without issues. :grinning:

1 Like