Unable to update Mailspring on Linux

I’m currently using Mailspring 1.10.8-8ea2a61f. When I start Mailspring it says "An update to Mailspring is available (1.1.0-6193b33c) with Download and Dismiss options.

Download takes me to the Mailspring download page. Mailspring - The best free email app

I installed the top option, “Linux (Auto-updating snap)” but ended up with 2 versions of Mailspring, one of which had no content. I assume that was the Snap version and I had originally installed the deb version.

I removed the snap version and downloaded the mailspring-1.11.0-amd64.deb version but opening that just gives me the option of uninstalling it.

I have lots of email accounts and I don’t want to have to set them all up again.

What am I doing wrong?

After downloading the new .deb version, simply uninstall the current one and then install the new one.

This so keep all mail accounts and mail and bring you to the newest version.



Problems at melbourne.co.uk perhaps?

I have no mail system

I am sorry to hear this. There is a problem with the latest Ubuntu version that prevents the installation. I fixed this in chore: remove deprecated linux dependency gconf2 by Phylu · Pull Request #2473 · Foundry376/Mailspring · GitHub which will be released with the next Mailspring version.

If you want, here is a custom build from the current master branch of the Mailspring repository that sohuld be installable and work: Nextcloud

I’m getting this repeatedly.


Is there perhaps a way to install the snap version and then migrate the settings/accounts over somehow?

You can try this by copying over the configuration folder from ~/.config/Mailspring to ~/snap/mailspring/common/ after installing the snap.

However, I have never tried this and am not sure whether this will work.

I’ll give it a go later. Thanks for help.

Let me know, whether it works. :slight_smile:

Fantastic, that does seem to have worked.

Still scanning several gmail accounts but there is a lot of old stuff in there.

1 Like