Unified inbox not refreshing

Did a search, not finding relevant topic…


New Mailspring install on LInux Mint 20. Mail comes in, see notification, unified inbox doesn’t show new mail.

To Reproduce…

Steps to reproduce the behavior:

Open mail.
See new mail notification.

Expected Behavior

Should be seeing new mail.


  • OS and Version: Linux Mint 20.2
    • Installation Method: Linux software manager
  • Mailspring Version: 1.9.2-6e14dad1

Additional Context

Probably not related but when I start Mailspring, a new mail window opens up automatically - I didn’t click anything to make this happen.

I’m using Mailspring on Kubuntu 20.10, so pretty much the same underlying system as Mint, also with Mailspring installed via the deb, and I don’t see what you’re reporting. (Not that helpful, I know!) The fact it opens an email automatically is odd: as you’d expect, it’s not supposed to do that.

Couple of things to check. First, have you tried uninstalling and reinstalling? And have you tried completely setting it up from scratch (i.e. remove your settings)?

And how many email accounts (and with which mail providers) do you have connected? Do you see the inboxes appear underneath the unified inbox when you expand it in the left-hand sidebar? And do the emails appear in those separated inboxes?

Thanks for your reply!

At this point, I’m working with the original install. I’ll try un/re, see if that happens.

I’ve only got three gmail accounts and yes, I see all three under the unified. I’ll click on one of those, then back to the unified and I’ll see emails from all three accounts. Yes - the emails show up in all three accounts.

That’s interesting: do I understand correctly that you see no emails in the Unified Inbox initially, but then if you check one of the individual email inboxes, the Unified Inbox then shows all emails as you’d have expected from the start?

Yup - that’s exactly what was happening. I’m no Linux expert but the install from MInt’s “software manager” incorporates the Flatpak install procedure - which I try to avoid (along with Snap) . I’ve got to wonder if that isn’t the cause of this issue.

So, I uninstalled, then went to Mailspring’s page and downloaded the .deb package. Ran through the install, configured my accounts and voilà - everything’s working exactly as it should be.

Thanks for the suggestion. All good here now.

1 Like

Ah, excellent! I had some problems with the snap myself, which is why I use the deb now! Sometimes, choice isn’t useful and “progress” isn’t an improvement! :roll_eyes: