When I input Japanese, the sentence disappears during the input

When I input Japanese, the sentence disappears during the input.
I attach a screen shot, but I am not certain at the time of character input, and the character I entered in the middle disappears even though I did not delete it.

I tried changing the input speed, but I did not improve the symptoms.
It also suspects Mailspring or base electron, as no problems have occurred with other applications.

There was no problem with English input.

OS: Windows 10 1903 [10.0.18362.175]
Mailspring: 1.6.2


(Originally posted by kometchtech on GitHub.)

Ok—I’ve tried a bunch of things, and here’s what seems to happen:

  • When you start typing, Mailspring enters text composition mode with the dropdown.
  • When you press enter to confirm your typing and advance the text cursor, it works fine. (I think?)
  • When you press TAB to control the composition dropdown (on the mac), it transfers keyboard focus to the To field and inserts the text suggestion there instead. (BAD)
  • When you click something to blur the composition dropdown and save your current composition, Mailspring enters a weird state where the text is still there but is not selectable. If you type another phrase, the text is overwritten (BAD)

Does that cover your scenario? I can’t quite tell in the GIF how you are exiting / confirming the text when it disappears.

Unfortunately, I think these problems are probably upstream in the Slate text editor. It looks like there are quite a few known problems that the maintainers are merging in to ianstormtaylor/slate#2368. I will debug exactly what is happening, especially with the focus issue, and see if I can fix that on our side.

I’m very sorry but I don’t think this will be fixed in time for the 1.6.3 release tomorrow. There are a few other important bug fixes I want to get out, but I’ll make sure to investigate this early this week.

Update

Hey @kometchtech, it looks like this works a bit better in the Slate examples (https://www.slatejs.org/#/rich-text) so I’m trying to narrow this down more and see what’s going on. Maybe there is something we can do today.

Update 2

It turns out that that this issue may be specific to our text editor and Chrome-based browsers. (When I posted above I was using Firefox!) I filed a bug with at least one behavior I observed: ianstormtaylor/slate#2906.

It looks like we may be able to patch around this though, looking to see now.


(Originally posted by bengotow on GitHub.)

It seems that you responded in 1.6.3, but when I checked it at hand, I did not improve it.
The phenomenon of disappearing of the character which I entered by myself before I decide Kanji conversion reappears.


(Originally posted by kometchtech on GitHub.)

Hey @kometchtech ahh interesting! Thank you for the extra detail. I’ll see if I can get that to happen. I didn’t realize that in your GIF, the panel was closing on it’s own.

Update

I set up my Windows VM to test this and I was able to reproduce exactly what you see, even after the fixes in 1.6.3. It looks like the IME input is conceptually similar on Windows, but Chrome emits different events. It’s quite broken, will see if I can fix this!


(Originally posted by bengotow on GitHub.)

Thank you for your patient investigation.
I do not know about this part systemically, but please contact me if there is any need.


(Originally posted by kometchtech on GitHub.)

Hi @bengotow, this happened in 1.7.2 as well.
I have the issue on both Windows 10 and Ubuntu 18.04, typing within tradition Chinese zhuyin input.

Changing input speed doesn’t improve the undetermined words disappearing.

But, the funny thing I found is that if I switch laptop mode from “efficiency” to “performance” with built-in device manager. The incidence of disappearing words reduces significantly, though it would still happen somehow.

Peek 2019-11-18 18-22


(Originally posted by kevinphys on GitHub.)

I’m facing the same issue.

Environment:
Mailspring: 1.7.2-4522b259 (electron 4.2.2)
OS: Windows 10
IME: Google Japanese Input

Expected behaviror:

  1. Enable Japanese IME in mail compose screen.
  2. Type keys to input (e.g. furuikeyakawazutobikomumizunooto) then underlined and unfinalized hiragana characters are shown (e.g. ___ ふるいけやかわずとびこむみずのおと ___ ).
  3. Press enter then input charcters are finalized (e.g. ふるいけやかわずとびこむみずのおと).

Actual behaviror:

  1. Enable Japanese IME in mail compose screen.
  2. Type keys to input, but sometimes all input charcters are cleared.
  • type: furuikeyakawazutobi, shown ___ ふるいけやかわずとび ___
  • (suddenly input characters are cleared)
  • keep typing remaining characters: komumizunooto, shown ___ こむみずのおと ___
  • (press enter)
  • only こむみずのおと part is finalized.

The timing of sudden clear is difficult to expect, but it’s easy to reproduce when I type long unfinalized sentense. This should be a critical issue for Japanese or Chinese writers.

I’m happy to do addional testing if nessesary.


(Originally posted by takedakn on GitHub.)

I also have problem with Vietnamese Input on Ubuntu Linux, so this is not limited to Windows. @bengotow If you can point me where can I start investigating this bug in the source code, I could give a helping hand.


(Originally posted by hieuxlu on GitHub.)

Typing Japanese in Mailspring on Windows not functioning as it should.

The exact same is happening to me, and this doesn’t happen anywhere else. I really love this email client, but I may switch soon due to this - it makes typing in Japanese impossible.


(Originally posted by norenTM on GitHub.)

When reply msg in Chinese, it trims characters after what I input at once.
Only happens when input in reply window, either in embedded or popup window.

It’s fine when write a new message.

Too follow up this issue, I dig more. Plain text reply seems ok, only encounter with HTML format content.

I’m trying to debug, any idea which file and where I should look into?


(Originally posted by chagel on GitHub.)