White Screen of Death

Description
Win64 Mailspring client screen goes white randomly. Maximizing the window or minimizing and resizing helps sometimes, but sometimes after a few moments, it goes white again.
It affects the software in general.
No particular behaviour triggers the error, no particular behaviour to reproduce.

Screenshots

Setup

  • OS and Version: Win64 19042.906
  • Mailspring Version: 1.9.0 87660767, then updating to 1.9.1 30ef80f the bug remains.

After click “Compose New Message” a new message window opens but the background is cover with white and freezing.

I see the same bugs in Windows 10 and Mailspring 19.1 version like that:

Hi, thank you for your answer. The problem is getting worse, unfortunately.

The Version 1.9.1-30ef802f

OS and OS Version? Installation Method? Those are relevant as well. The Bug Report template is provided for a reason.

I’m having that all the time too, so annoying.

Windows 10 Education 20H2
Mailspring 1.9.1-30ef802f

1 Like

Same Problem.
Windows 10 20h2
Mailspring 1.9.1-30ef802f
No Entry in Windows Log.

Also experiencing this randomly as well…

Windows 10 Pro 20H2
Mailspring 1.9.1-30ef802f

Make sure you Vote for this issue at the top to help raise its priority. Thanks!

same problem, happens unpredictably but has been more frequent recently for me

Windows 10
Mailspring 1.9.1-30ef802f

1 Like

I got the same bug, my theme is black so the screen is black also:

Even if you close it, and reopens MailSpring it still displays

You have to kill the process via CTRL+ALT+SUPPR to get rid of it

Windows 10

Hi I am in windows 10 latest updates and when I press the button to compose a new mail , new windows appears but the main window of mail spring gets in blank.
The only way to see again the main windows is to minimize it and open again the window

it’s very annoying, also happens the same issue when you read an email that has an attachment and you have the option to show the icons of the attachments, I had to disable it and after a long time of why in some mails the screen was getting all blank.

I confirm that this issues of blank screen appears when microsoft Edge browser is running, so if I close Edge browser mailspring works fine, but when I open Edge browser (my default browser ) again, all this blank screen issues starts again.

Some type of conflict exist, this is a really problematic issue for Windows users.

Me too after update to 1.9.1-30ef802f

Windows 10 pro 20H2

Hi I can add that I confirmed that this issues of blank screen appears when microsoft Edge Browser is running, so if I close Edge browser mailspring works fine, but when I open Edge browser (my default browser ) again, all this blank screen issues starts again.

Some type of conflict exist, this is a really problematic issue for Windows users.

It will be interesting if all the post before me, can also check if the issue is only when ANY WEB BROWSER is open, because could be issue of chromium related so could be the issue with Edge and Chrome browsers

And this will give a big hint to the developers.
Thanks!!!

1 Like

Whoa this is a pretty interesting detail, trying to reproduce it with Edge running now. I wonder if the blank / black / white states are caused by different issues or the same problem.

1 Like

Hey folks! Thanks for all the details here, I’ve been running two Windows 10 VMs for an hour or so and haven’t been able to repro this yet :-/ If you get a chance, there are two pieces of info that might help narrow this down:

  • I did some Googling and there are some reports in recent Electron issues of this happening on machines with Nvidia graphics cards, and when that’s the case the fix is to launch the app with the --disable-gpu option. To do that with Mailspring, you’d open Command Prompt and type something like:

    C:\Users\<<<your username>>>\AppData\Local\Mailspring\mailspring.exe --disable-gpu

    Make sure you’ve fully quit the app beforehand and don’t just bring it back to the foreground. If that resolves the white screen of death it’ll really help narrow it down.

  • This sounds somewhat similar: [Bug]: Window contents disappear when webcontents is focused after a navigation all while the window is hidden · Issue #28255 · electron/electron · GitHub, but I haven’t been able to get it to happen with Mailspring. Any chance the window goes white / black only if you cover it with another window that is fully maximized / hiding the Mailspring window?

Hope we can get this sorted soon, thanks everyone—

1 Like

It happens to me with an intel (surface) graphics card