Account Set up fails with SMTP error

Description

An account in mailspring can not be set up when the SMTP server refuses to send to ‘email@invalid.com’. This behavior is strange. We have a server that is limited in which domains it relays to, ‘invalid.com’ is not one of them of course. There should at the very least be an override button in the interface to skip such a verification but in my opinion it would be better not to use this verification at all.

To Reproduce…

The description above should give enough of an indication on how to reproduce this.

Expected Behavior

Frankly, I wouldn’t expect an email client to send to ‘email@invalid.com’ to verify its configuration. But if you absolutely must, then you should at least give an option to proceed in any case when verification fails.

Setup

  • OS and Version: Debian Testing and Ubuntu 20.04
    • Installation Method: DEB , snap
  • Mailspring Version: 1.9.1

Additional Context

Is there a workaround that would allow me to use mailspring until this is fixed?

Although not strictly the same, this feature request is related: Make SMTP or IMAP optional (Read-only or Send-only accounts)

If I’m understanding you correctly, you want both IMAP and SMTP, but the two use different domains? Is that correct?

No, in my case we have the same server for IMAP and SMTP, but the mail server in question is for internal communication only. It’s configured to refuse to relay to any domains that are not specifically listed. So, it fails the test because the server refuses to send to ‘invalid.com’. I do not want to skip SMTP configuration. I guess our use case makes the SMTP test of mailspring fail leaving me unable to complete the account configuration. I would rate this as a bug, not a feature request.