Bug: Crash and sync error due to inability to create "Snoozed" folder


I am using Mailspring for two accounts with zoho mail. When I try to snooze an e-mail in one of these accounts, Mailspring crashes. After restarting Mailspring, I get sync errors for the account that I tried snoozing the mail with, rendering Mailspring unusable.

The logs tell me that the error is caused by the inability to create the folder Mailspring/Snoozed:

313586 [2021-06-01 14:52:58.573] [main] [info] Identity created at 1586883882 - using ID Schema 1
313586 [2021-06-01 14:52:58.574] [main] [info] ------------- Starting Sync (my-address@zoho.com) ---------------
313586 [2021-06-01 14:52:58.578] [metadata] [info] Metadata delta stream starting…
313586 [2021-06-01 14:53:01.044] [main] [info] Waking all workers…
313586 [2021-06-01 14:53:01.044] [main] [info] Metadata expiration 0 is further in future than wake time 0
313586 [2021-06-01 14:53:01.045] [background] [info] Marking all folders as busy
313586 [2021-06-01 14:53:01.066] [background] [info] Syncing folder list…
313586 [2021-06-01 14:53:03.651] [background] [error] Could not create required Mailspring folder: Mailspring/Snoozed. ErrorCreate
313586 [2021-06-01 14:53:03.662] [background] [critical]

*** Mailspring Sync
*** A C++ exception occurred during program execution:
*** UNIQUE constraint failed: Folder.id


The issue is reproducible and seems to be caused by a limitation of Zoho: Via the Zoho mail web interface I am not allowed to create a folder (or any subfolder) named “Snoozed” either.

The problem could be worked around by making the name of the “Snoozed” folder configurable in Mailspring instead of hardcoding “Mailspring/Snoozed”.

Email Provider

Zoho (IMAP)


  • OS and Version: Fedora Linux 34
  • Installation Method: Snap
  • Mailspring Version: 1.9.1