Buttons not working with Horizontal reading pane

I’m thrilled (really!) with the new horizontal reading pane Mailspring, but I’ve noticed that the buttons don’t work properly in the new layout. There is a row of buttons to archive, star and trash messages at the top of the reading pane:


But clicking them has no effect and nothing appears when I hover over one. If I switch back to the three column view (aka “vertical reading pane”) the buttons work as expected.

For most I know the keyboard shortcut, which is kind of better anyway, but I don’t know a shortcut for :+1: when a message should not have been marked as spam.

Yours, I believe, @Phylu.

@amandabee Thanks for the bug report. I tried to reproduce this, but were not able to on my machine with the 1.9.1 version.

Your screenshot looks like you are in some kind of filter mode or Spam folder. Does this work in the inbox? What operating system and mailspring version are you using?

I consistently see the same behavior in the Inbox and other folders. I took a screenshot of Spam just because I know there’s nothing revealing, no confidential work memos, in my Spam folder.

If I switch over to the vertical preview pane the buttons work fine. It only happens in the horizontal preview.

I’m running Ubuntu 20.04, Mailspring 1.9.1-30ef802f

1 Like

I’m on Ubuntu 20.04 (actually Pop! OS) and Mailspring 1.9.1-30ef802f as well, but I can’t reproduce either. :confused:

I installed from Deb. Are you installed from Snap, @amandabee?

I believe that I’m installed from Snap, yes.

Weirdly, if I switch themes to “less is more” the buttons work but they overlay the subject line:

They lay over the message itself as I scroll down, but continue to work.

Here’s a better example of the buttons on top of the message.

Tried switching between themes and in Ubuntu (the theme) the buttons don’t show any icons and there’s no information when I hover:

Taiga is the theme I was using. Darkside and Dark work like Taiga: Buttons are visible but they don’t do anything and there’s no text when I hover over the buttons. If I switch over to the vertical preview pane, that works.

Thanks for the explanation! I can confirm that this is an issue with the non default themes. However, the buttons work for me with any theme, I just don’t see them in Ubuntu (there is definitely the color wrong) and have this strange overlay in the Less is More theme (some margin/padding issue as it seems).

Here is the Ubuntu Theme with me hovering the Spam button, and the Tooltip appears.
Bildschirmfoto von 2021-05-06 21-19-11

I will definitely look into this. However, if you have more information, why they are not working, let me know. Perhaps there is some info in the Dev Console.