Cannot attach files stored in NTFS partition with snap version

I’m running Mailspring snap in Manjaro 17.1.6.
I have a second NTFS partition, and when I try to attach files stored there Mailspring returns an error message:

The icon-less folders are links to folders on NTFS partition:

I’ve already connected mailspring to removable-media interface with sudo snap connect mailspring:removable-media, and I have also checked owner and permissions of the NTFS partition through /etc/fstab, but none of that worked.

I’m not sure if it’s due to snap confinement or its a Mailspring problem at this point. What do you think?

It’s not Read-Only, in fact I can create and delete files normally; the problem is that I cannot access it with Mailspring snap to attach files. Also, installing mailspring snap in --devmode or in --classic didn’t help.

I noticed that Skype snap, installed with classic confinement, can read the files stored in NTFS partition. Same thing with Atom snap and VSCode snap. So I guess the problem is that Mailspring snap doesn’t support classic confinement.

After a little of research, I’ve found that binding directories from NTFS partition to /home makes them browsable from snap apps with no classic confinement, and now I can attach files.

Not sure if mark this as solved though, since I cannot really browse NTFS files without this workaround.

(Originally posted by nihil21 on GitHub.)

Hey! Thanks for digging in to this—I think you’re right that this is most likely an issue with snap confinement. It might be a good idea to bring it up in the snapcraft forums ( and see if it could be fixed in snapd. In the meantime I’ll leave this open so it’s easier for folks to find!

(Originally posted by bengotow on GitHub.)

I was told to type:
sudo snap connect mailspring:removable-media
and that would allow mailspring to access other drives mounted on my system. It had no effect (and no error message was raised either).

(Originally posted by davenorthcreek on GitHub.)

@davenorthcreek did it work for you? I tried sudo snap connect mailspring:removable-media but with no luck. But I may have a slightly different scenario I am not sure if it fits in the current issue or it is for another (or maybe even against snap).

I am on an openSUSE Leap 15.1 machine, and partitions and volumes everything is managed by LVM. I installed Mailspring via snap. The issue is that I cannot attach a file from a different Volume: I am on /dev/system/home/ and I want to attach a file from /dev/storage/



OS files




As you can see there is not /storage in the Mailspring attachment list option, and if I even click on the location shortcut on the left, it still shows me the content of /.

Any idea? Thank you

(Originally posted by ncounter on GitHub.)

One hack that worked - create a symlink to your /storage partition from your home directory and connect that way.

If that doesn’t work, what I ended up doing was mounting my /data partition in /media/data as well as at /data. I updated a bunch of shortcuts in my file browser and now the problem is gone. Mailspring with the sudo snap connect mailspring:removable-media addition looks for partitions mounted in /media, not partitions mounted from the root (because it thinks it’s looking for usb sticks I guess).

If that doesn’t work, just switch to the non-snap version.

(Originally posted by davenorthcreek on GitHub.)

Unfortunately, none of the hacking options worked. I am not willing to uninstall and reinstall actually, so I will just live with it as it is: I can always copy the attachment under a temp dir for a while of sending an e-mail, it’s not a big deal. If it turns out I will figure out the right hack to make it work I’ll also update you here. Thanks for your support.

(Originally posted by ncounter on GitHub.)

Using Mailspring 1.4.2 on KDE Neon User Edition. The Snap install sandbox does not allow me to browse or attach files from my shared drives, automatically mounted on boot at /shared

Drives do not show when browsing, and if attachments are dragged to Mailspring the error ‘file not found or insufficient permissions’ is displayed. This makes the Snap install unusable for me. The problem does not occur with the .deb install - browsing and attachments are fine.

(Originally posted by timgoodwin123 on GitHub.)

Hello, currently snapd only allow regular file access from /mnt , /media , and /run/media , you may want to consider to move the mount point under these directories after connecting the removable-media interface.

(Originally posted by Lin-Buo-Ren on GitHub.)

The drive I am trying to access is not removable media but a separate internal hard drive on which I have /home mounted. This enables me to re-install the OS without affecting all the files in /home
As Snap does not allow access to this drive, I can’t attach any documents in /home to mail, rendering the Snap version of Mailspring useless to me. I’m currently using the .deb file.

(Originally posted by timgoodwin123 on GitHub.)

@timgoodwin123 Note that the access of files in /home is granted via the home interface. The removable-media interface name is misleading as it simply allows access to /mnt and */media , if you move the /shared mount point under /mnt/shared or /media/shared` the files in the /shared file system should be accessible by Mailspring.

(Originally posted by Lin-Buo-Ren on GitHub.)

My home directory has to be called /home or the OS can’t find the config files it needs. Because my /home directory is mounted on a drive on which the OS is not installed, Mailsping will not allow me to browse to it or attach files from it with the Snap package.

(Originally posted by timgoodwin123 on GitHub.)