Connection Error - Unable to connect to the server / port you provided. (SMTP)

Description

To Reproduce…

Steps to reproduce the behavior:

  1. Try to connect GMail account via prompts
  2. Give applicable (all) permissions to MailSpring
  3. Get the success page within browser directing me back to the email client
  4. Client says ‘Connecting…’
  5. Gives error:
    Sorry, we had trouble logging you in
    Connection Error - Unable to connect to the server / port you provided. (SMTP)

Expected Behavior

Expected the MailSpring client to connect to my GMail account and to use as normal

Screenshots

Setup

  • OS and Version: Windows 10 Home
    • Installation Method: From MailSpring website
  • Mailspring Version: Cannot provide, app does not show a menu until the email account is connected

Additional Context

I was using MailSpring just fine until earlier today (9/20/2022) when I was unable to send messages. Would receive the error: Connection Error - Unable to connect to the server / port you provided. (SMTP).

Restarted application multiple times with same result. Tried different messages with same result.

Uninstalled MailSpring and reinstalled and now I receive the same error when trying to connect to my gmail account for the “first” time.

IMAP and POP are enabled through GMail. All of my folders are accessible through GMail.

I have also tried multiple GMail accounts with the same result. Seems that the client is having issues connecting to GMail as a whole from my end.

Same results with multiple accounts. Pasting the provided link does not resolve the problem, gives same result.

MacBook Pro (14-inch, 2021), macos 12.6

Same result, same issue, It’s been a month now and no change

I wonder if this is related to:

Could it be that Gmail is also stopping the test email from being sent to email@invalid.com. If so, this could be why mailspring is always reporting a SMTP error :person_shrugging:

If anyone can try the file I’ve generated a test, that would be great. Just a shot in the dark.

Yes, I’m having trouble simply setting up my email in Mailspring. I also us Aqua Mail on my android phone with no issues. See attached screenshot.

Is there any update to this issue? I have been having this issue for several weeks, and I have had to make the switch to Thunderbird (an app I really don’t care for) because I can’t access my Gmail account. The odd thing is that it’s only my Gmail account. My work accounts that are through Google Workspace work fine, but my personal fails with this same error. The log has said Error 4 when I’ve checked it in the past.

This has been fixed since 1.10.7

But there are releases after this one :grin:

What in the world… I’m running 1.10.8 on Ubuntu as a Snap package (I have tried as a binary as well), and I’m still running into this… I’ll try as a binary again?

Nope, same error. Downloaded from the website, installed fine, but no dice on my personal Gmail account. The weird thing is, it worked fine for so long, but then suddenly stopped working. I wasn’t trying to add it for the first time, it stopped working after having already been logged in.

Might not be able to help, but what’s in the log

image

There doesn’t appear to be a “View Log” option for me when I get the error on either version of the app. I get, “Connection Error - Unable to connect to the server / port you provided. (IMAP)” and a “Try Again” button. I have seen the “View Log” button in the past, and I remember it gave me simply something like, “Error 4”. That is the error number, but I don’t remember the exact syntax of its report.

This error was specific to SMTP (as it was historically sending to an invalid email, when testing)

Seems like you issue is separate. Maybe see if there’s another discussion that relevant to your issue (your specific provider/error).

Hi Glenn, I just saw these updates and have tried uninstalling Mailspring and re-downloading with the same results. I have also upgraded my OS to Windows 11, vs Windows 10 in the original breakdown from this post. Anything I can do or provide that might help solve this problem? Or potentially identify if I am running into a different one?

If you have anything like the one below, that might help. Especially the View Log info. As this has been rectified it’s most likely an office365, gmail or some similar issue

image

Unfortunately I did not get that log option.

STRs -

1 Download the launcher from the Mailspring Website
2 Run the launcher
3 Choose Gmail from the list of options in the “Connect an email account” menu
4 Be directed to the Google Sign-In page on the latest version of Chrome (also tried Incognito & Edge with same results)
5 Successfully be signed in and directed back to the Mailspring app
6 Receive attached error screen

Sorry, for the delay. Your error doesn’t sound related. Might have something to do with:

If not, there may be logs in the folder I mention over on that post :man_shrugging: