Database Error and unable to launch app after installing V1.10.0

Made an account just to jump in and say thank you for this fix/workaround. I really appreciate it.

That is all.


thanks for temporary solution, apparently it worked for me

1 Like

Thank u for taking time to share this fix, greetings!

Thanks for the effort, keep it going

Hey buddy. @Predeactor Do you have any solution for this sync error?



I have subscribed to mailspring but i could not find any solution for this error. It is really frustrating. I would really appreciate if you could help on this one? i could not able to reach the support team as well. Please help. kindly point me to the right direction if you can…

Thank you for this temporary solution, although I don’t know what I did wrong that the message came back. My simple solution has been to leave the installer on hand to start it along with my computers, this way I don’t lose the configuration data and everything goes back to normal.

Hey folks! Thanks for your patience and help tracking this down - we’ve published the Mailspring v1.10.1 update this morning and it’ll resolve the issue launching the app on Windows.

The underlying problem was that our AppVeyor CI service quietly transitioned from ia32 (32-bit) to x64 (64-bit) when we bumped Visual Studio versions, and some native modules in our Electron app were built for the CI machine’s architecture instead of the app’s target architecture, resulting in successful but un-runnable builds. It took a while to figure out this was happening and I sincerely apologize.

Getting the Update

The app’s auto-updater is running in the broken version, so if you launch Mailspring and see the sqlite is not a Win32 application error, you can wait a few minutes on that screen while the update downloads, and then force quit / log out + log back in to continue with the fixed version of Mailspring. (Unfortunately clicking “Ok” in the dialog opens the same version and not the updated version of the app.)

You can also download the latest version from Mailspring - The best free email app and run MailspringSetup.exe to install the update.

Future Changes

I’m looking into Electron changes we can make so that the Windows autoupdater is less aggressive, and will also make changes to our CI and testing processes to make sure this doesn’t happen again. We tested the Electron 14 PR on Windows but not the final CI build, which was a mistake for sure.

I sincerely apologize for any lost time and work caused by this update. If you’re a Mailspring Pro user, feel free to email me at and I’ll credit your account for the quarter as thank-you for using Mailspring.

On the plus side, the Electron 14 update brought a lot of bug fixes, performance, and security updates to Mailspring’s core and will make it easier for us to stay on top of improvements to the Electron platform going forward. Good things ahead!


vroom! the dev team came in hot! time for some rest :stuck_out_tongue:

Now it works fine … Thanks for your great work. :grinning: :grinning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.