Database Error and unable to launch app after installing V1.10.0

You can check your version under the three line menu in the upper-right part of the Mailspring app. I just hesitate calling it a “solution” since you’re just reverting to the previous build–not actually fixing the bug. That’s what I had to do, uninstall and reinstall. I didn’t lose my preferences or account settings, however, which was cool. :slightly_smiling_face:

Having the same issue - cannot go back to 1.9.2 and I deleted anything having to do with Mailspring. It won’t let me start fresh and I continue to get the error message “We encountered a problem with your local email database. We will now attempt to rebuild it.” and nothing happens. So frustrating, especially for something you pay for!!!

Well that’s temporary, there’s no real official answer so far and we must wait for a hotfix, hopefully soon, in the meantime, we’re just finding alternatives to rollback to a latest working version!
The point of my action was to make everyone sure to not erase any settings… So, yeah… :stuck_out_tongue:

Hi there,
Have you tried my solution, if not, try it, this probably could work!

If not, you can check my other post on how to make a complete reinstall without losing your data:

Hi Everyone,

I am very sorry for the inconvenience this is bringing to all of you! I am trying to resolve this as soon as possible. Thanks a lot @Predeactor for the great workaround described.

I will document any progress regarding a the development of a solution here:

I hope that I can find a solution fast in order to cut a bugfix release for this.


I hope this is the right catalyst to implement a switch in settings to let the user update when they want to. I’ve opened issues on that in the past but the developer is way too opinionated for his own good. Not the first time mailspring mucks up after an update, you’d think by now the decision to make updates optional would have been made.

1 Like

Might want to append the guide to rename update.exe because it auto updates the next time mailspring.exe is launched (user quit, logout, reboot, crash, whatever).

[ Solved ]*******

This is how you can survive this 1.10 update. btw noob here.

uninstall mailspring.

–Edit : as noted by @predeactor skip this step and try if you do not want to lose your settings and data (delete the items inside this folder
C:\Users\XXXX\AppData\Local\Mailspring )–
{XXXX- Username}

download the Mailspring v.1.9.2 here :

and install the same.

open and sign up and add just 1 account.

close the Mailspring app in the Task Manager to shut it completely.

go to C:\Users\XXXX\AppData\Local\Mailspring

Find the file “Update.exe”

rename the file into “Update.exe.old”

go to this folder


find and right click on the file “mailspring.exe” and Click " Send to - Desktop (create Shortcut)"

come to desktop and find the “mailspring - Shortcut”.

Use only that shortcut file to open the Mailspring from hereafter.

If error occurs repeat from step one.

Hope this Helps!

Done, thank for pointing this out, hope it won’t break the app!

Your solution erase user’s data, settings, etc… This is not a good thing. My guide does not do that and my guide cover most of what you’ve written already without any user’s data deletion.
Just wanted to let you know. Maybe you could consider pointing your guide to mine too :grinning_face_with_smiling_eyes:

Could you kindly link to this guide that does not break the app? Please and thank you :slight_smile:

Here you go, Database Error and unable to launch app after installing V1.10.0 - #11 by Predeactor
Hope the best for your fix!

1 Like

This seems to have worked, thank you! Is Mailspring working on a fix for this? Where would we check for communications from them regarding it? Any chance you know?

I’ve been emailing Ben (One of the author) about this issue, he answered me by telling me they’re working on it ASAP!
There also is this post made by Phylu, so you can check the progress here!


Hello, thanks a lot you solve my day, I only registered to thank you for the temporary solution. I have always used Mailspring as my mail app, so it was a great workaround until the next update fix it.


1 Like

Ayy! Thank for the kind words, it’s very appreciated!

1 Like