Emails with same To/From address disappear from Inbox


All contact form entries on my WP website are forwarded to my mail account. The address for sending and receiving the emails is identical in this case.

After receiving a new mail, it is visible in the Inbox for a few moments and then disappears. The email sporadically pops up in the list for a second and then vanishes again. It is still in the Inbox on the server and is correctly shown by other clients, but not displayed by Mailspring.


  • OS and Version: Linux Mint 19.2 Cinnamon
  • Mailspring Version: 1.7.2

(Originally posted by Rakantor on GitHub.)

I’ve also been having this problem with email reminders I send to myself, but hadn’t realised that it might be specifically because the send/receive addresses are the same. But this seems to explain why these ones in particular never seem to show up. (I’ve been suffering from this bug with emails that have been in an inbox for more than a week or so, but this explains why my reminders seem to disappear almost instantly).

(Originally posted by thosgood on GitHub.)

I just came across this same case. In my case, it was an email I sent to myself and to another mailbox which forwards to myself. I received it, and a few seconds later, it disappeared. I have the same mailbox connected with Outlook on another computer, it was appearing in Outlook, but not in Mailspring. I’m using Mailspring on Ubuntu 20.04.

(Originally posted by wadih on GitHub.)

I was unable to reprodue the issue on the current master branch. Can somebody of the original posters please confirm that this is still an issue?

I am on Pop!_OS 20.10 (Linux 64 bit) using Mailspring 1.8.0-8983dca2 which I just installed today.

I added my Gmail account. If I send an email to myself, it appears in the Sent Mail folder but it never appears in my Inbox. If I look in Gmail, it is likewise in the Sent folder but not in the Inbox.

I didn’t notice if it appeared in the Inbox briefly, as others have stated.

1 Like

More duplicates:

Exact same problem here in Mailspring. It’s a deal breaker for me so I hope a fix soon. I send a lot of self emails for work, reminders and other stuff that I need to save by using rules.

Tested this issue and was unable to reproduce. I’m using a Gmail account. Tested it with sending from Mailspring and from the Gmail UI. It came through properly on both occasions.

Mailspring version: 1.8.0-8983dca2
Operating System: Linux, Elementary OS 5.1.7 (Ubuntu 18.04.4)

I just tried sending myself an email on my desktop computer and on my laptop. It worked on my desktop computer, but it did not work on my laptop. Both are using Mailspring 1.8.0-8983dca2 and both are Pop!_OS 20.10.

Can you please try to provide the Mailspring and Mailsync Logs in case that this happens? This may help figuring out what the issue is:

Mailspring Logs:

  1. Go to “Developer” > “Toggle Developer Tools”
  2. Chose the “Console” tab
  3. Press “Clear Console” (Ctrl + L)
  4. Reproduce the Issue
  5. Do a right click inside the console and click “Save as”
  6. Clear any personal information from the debug file that you now have created
  7. Attach the file here

Mailsync Logs:

  1. Go to your Mailspring User Directory:
    • Mac: ~/Library/Application Support/Mailspring
    • Windows: C:\Users\<Your User>\AppData\Roaming\Mailspring
    • Linux: $XDG_CONFIG_HOME/Mailspring or ~/.config/Mailspring
  2. Look for the file mailsync-xxxxxxxx.log wheras the xxxxxxxx denote the internal id of your e-mail account
  3. Attach the file here

If the problem is email address related, you can try to use “+” sign. This is supported by most e-mail providers (Gmail included) and technically anything after the plus sign (with the sign itself included) is ignored by mail routing and will be delivered to e-mail address as if the +something was not present.
If your mail is you can send mail to Similarly you can use the same technique e.g. to register with your e-mail address at any untrusted site to be able to quickly filter out spam. If you use to register at unknown/untrusted site you can easily set-up a spam rule that ignores any mails received to this address in the future as unsolicited no matter where it comes from.
If you are Gmail user you have another trick up the sleeve. Gmail generally ignores dots in the e-mail address. If you add additional dots to you e-mail address between letters they will be ignored. The,, are technically the same e-mail address. (I spoke to several unlucky Gmail users that created their mail addresses in the early days of Gmail when this was not supported and for some this does not work and if they add a dot and such e-mail exists for another gmail user they will not receive the mail).

1 Like

@Phylu: I was able to reproduce this bug with the current Windows version 1.9.1-30ef802f, which I have freshly installed yesterday. Its a vanilla install without cloud account (purely local).

The server is a Dovecot IMAP Mailserver running current Debian stable.

Here is what I did:

  1. Opened Mailspring
  2. Used my iPhone to send a message to myself (reminder-style), the usual case I do here.
  3. The Mail appeared in the Inbox, probably due to some IMAP Idle message (so far so good)
  4. Then I pressed F5 to initiate a mail sync
  5. At that point, the message disappears from my inbox.

Note, that both a Thunderbird instance and the Apple Mail client on my iPhone still show the mail in the Inbox. I cross-checked this on my server, the mail is still physically present.

Here are the console Logs:

This I got during step 3, line wraps by me:

database-store.ts:203  _executeInBackground took more than 100ms - 188msec (8msec in background): 
SELECT `Thread`.`id` FROM `Thread` WHERE `id` 
IN (SELECT `id` FROM `ThreadCategory` WHERE `ThreadCategory`.`value` 
IN ('LkW1y...cp1ep') 
AND `ThreadCategory`.`inAllMail` != 0  
ORDER BY `ThreadCategory`.`lastMessageReceivedTimestamp` 
ORDER BY `Thread`.`lastMessageReceivedTimestamp` DESC

This was logged during Mail sync (steps 4+5), again, line wraps by me:

mailsync-process.ts:323 Sending to mailsync 198a0537 {type: "queue-task", task: ChangeUnreadTask}
mailsync-bridge.ts:197 Sending `wake` to all mailsync workers...
sendSyncMailNow @ mailsync-bridge.ts:197
(anonymous) @ window-event-handler.ts:112
dispatch @ command-registry.ts:62
(anonymous) @ keymap-manager.ts:225
_fireCallback @ C:\Users\torben\AppData\Local\Mailspring\app-1.9.1\resources\app.asar\node_modules\mousetrap\mousetrap.js:616
Mousetrap.self._handleKey @ C:\Users\torben\AppData\Local\Mailspring\app-1.9.1\resources\app.asar\node_modules\mousetrap\mousetrap.js:677
Mousetrap.handleKey @ C:\Users\torben\AppData\Local\Mailspring\app-1.9.1\resources\app.asar\node_modules\mousetrap\mousetrap.js:1008
_handleKeyEvent @ C:\Users\torben\AppData\Local\Mailspring\app-1.9.1\resources\app.asar\node_modules\mousetrap\mousetrap.js:737
mailsync-process.ts:323 Sending to mailsync 198a0537 {type: "wake-workers"}
database-store.ts:203  _executeInBackground took more than 100ms - 207msec (9msec in background): 
SELECT `Thread`.`id` FROM `Thread` WHERE `id` 
IN (SELECT `id` FROM `ThreadCategory` WHERE `ThreadCategory`.`value` 
IN ('LkW1y...cp1ep') 
AND `ThreadCategory`.`inAllMail` != 0 
ORDER BY `ThreadCategory`.`lastMessageReceivedTimestamp` DESC LIMIT 200 OFFSET 0)  
ORDER BY `Thread`.`lastMessageReceivedTimestamp` DESC

The mailsync logs around this look as below. Please not, that the distinction between step 3 and 4/5 is to the best of my knowledge, I’m not 100% sure here.

So, during step 3 we had this:

34656 [2021-05-02 11:23:20.528] [foreground] [info] Idle exited with code 0
34656 [2021-05-02 11:23:20.538] [foreground] [info] syncFolderChangesViaCondstore - INBOX: modseq 355417 to 355418, uidnext 94004 to 94005
34656 [2021-05-02 11:23:20.550] [foreground] [info] syncFolderChangesViaCondstore - Changes since HMODSEQ 355417: 1 changed, 0 vanished
34656 [2021-05-02 11:23:20.589] [foreground] [info] Idling on folder INBOX
34656 [2021-05-02 11:23:21.247] [foreground] [info] Idle exited with code 0
34656 [2021-05-02 11:23:21.258] [foreground] [info] syncFolderChangesViaCondstore - INBOX: modseq 355418 to 355419, uidnext 94005 to 94005
34656 [2021-05-02 11:23:21.268] [foreground] [info] syncFolderChangesViaCondstore - Changes since HMODSEQ 355418: 1 changed, 0 vanished
34656 [2021-05-02 11:23:21.269] [foreground] [info] Idling on folder INBOX

Somewhere in between the two steps I got this:

34656 [2021-05-02 11:23:57.404] [main] [info] [local-4321d339-3201] Running ChangeUnreadTask performLocal:
34656 [2021-05-02 11:23:57.408] [main] [info] [local-4321d339-3201] -- Succeeded. Changing status to `remote`
34656 [2021-05-02 11:23:57.729] [foreground] [info] Idle exited with code 0
34656 [2021-05-02 11:23:57.729] [foreground] [info] [local-4321d339-3201] Running ChangeUnreadTask performRemote:
34656 [2021-05-02 11:23:57.741] [foreground] [info] [local-4321d339-3201] -- Succeeded. Changing status to `complete`
34656 [2021-05-02 11:23:57.753] [foreground] [info] syncFolderChangesViaCondstore - INBOX: modseq 355419 to 355420, uidnext 94005 to 94005
34656 [2021-05-02 11:23:57.764] [foreground] [info] syncFolderChangesViaCondstore - Changes since HMODSEQ 355419: 1 changed, 0 vanished
34656 [2021-05-02 11:23:57.765] [foreground] [info] Idling on folder INBOX

The actual start sync should be this:

34656 [2021-05-02 11:24:00.117] [main] [info] Waking all workers...
34656 [2021-05-02 11:24:00.117] [background] [info] Marking all folders as `busy`
34656 [2021-05-02 11:24:00.128] [foreground] [info] Idle exited with code 0
34656 [2021-05-02 11:24:00.141] [background] [info] Syncing folder list...
34656 [2021-05-02 11:24:00.142] [foreground] [info] syncFolderChangesViaCondstore - INBOX: modseq 355420 to 355420, uidnext 94005 to 94005
34656 [2021-05-02 11:24:00.143] [foreground] [info] Idling on folder INBOX
34656 [2021-05-02 11:24:00.183] [background] [info] syncFolderChangesViaCondstore - INBOX: modseq 355420 to 355420, uidnext 94005 to 94005
34656 [2021-05-02 11:24:00.196] [background] [info] syncFolderChangesViaCondstore - Sent: modseq 2968 to 2969, uidnext 2630 to 2631
34656 [2021-05-02 11:24:00.220] [background] [info] syncFolderChangesViaCondstore - Changes since HMODSEQ 2968: 1 changed, 0 vanished
34656 [2021-05-02 11:24:00.220] [background] [info] - Updating message m7JETirxWYFkNjkJD7NgR813fjTGC46XzCAjcUHr7
34656 [2021-05-02 11:24:00.220] [background] [info] -- UID (94004 to 2630)
34656 [2021-05-02 11:24:00.220] [background] [info] -- FolderID (LkW1y...cp1ep to JmExT...Mf7no)
34656 [2021-05-02 11:24:00.239] [background] [info] syncFolderChangesViaCondstore - Drafts: modseq 2948 to 2948, uidnext 1083 to 1083
34656 [2021-05-02 11:24:00.250] [background] [info] syncFolderChangesViaCondstore - Archives.2021: modseq 643 to 643, uidnext 302 to 302
34656 [2021-05-02 11:24:00.262] [background] [info] syncFolderChangesViaCondstore - Trash: modseq 36515 to 36515, uidnext 28280 to 28280
34656 [2021-05-02 11:24:00.272] [background] [info] syncFolderChangesViaCondstore - Junk: modseq 82064 to 82064, uidnext 43888 to 43888

The folder “Sent” is (as you might expect) the one, where outgoing mails are archived by my Mail Clients.

After that, I’m getting a whole log messages like the following, where modseq from/to and uidnext from/to values are identical, without much mor information than that, for example:

34656 [2021-05-02 11:24:00.707] [background] [info] syncFolderChangesViaCondstore - Z1 data.folder1: modseq 1 to 1, uidnext 65 to 65
34656 [2021-05-02 11:24:00.717] [background] [info] syncFolderChangesViaCondstore - Z1 data.folder2: modseq 1 to 1, uidnext 7 to 7
34656 [2021-05-02 11:24:00.729] [background] [info] syncFolderChangesViaCondstore - Z1 data.folder3: modseq 1 to 1, uidnext 4 to 4
34656 [2021-05-02 11:24:00.739] [background] [info] syncFolderChangesViaCondstore - Z1 data.folder4: modseq 28 to 28, uidnext 21 to 21

… and ending with …

34656 [2021-05-02 11:24:02.800] [background] [info] Sync loop deleting unlinked messages with phase 2.
34656 [2021-05-02 11:24:02.812] [background] [info] Sync loop complete.

Intermixed (probably from multi-threading) I also see the following messages, they appear around folders, that haven’t been touched at least for days, no mail filters access these folders, I only use them for manual archiving:

34656 [2021-05-02 11:24:01.129] [metadataExpiration] [info] Scanning for expired metadata
34656 [2021-05-02 11:24:01.133] [metadataExpiration] [info] -- Will wake for next expiration in 7200sec
34656 [2021-05-02 11:24:02.167] [foreground] [info] Idle exited with code 0
34656 [2021-05-02 11:24:02.178] [foreground] [info] syncFolderChangesViaCondstore - INBOX: modseq 355420 to 355420, uidnext 94005 to 94005
34656 [2021-05-02 11:24:02.178] [foreground] [info] Idling on folder INBOX
34656 [2021-05-02 11:24:02.346] [background] [warning] [SLOW] Transaction=saveFolderStatus > 80ms (148ms, 0 waiting to aquire)

I don’t think that this is related to the issue at hand though.

If you need the unabbreviated logs or other information (I’ve tried to keep the hash codes good enough to correlate them), please send me a PM to torben nehmer net. Same goes for any information you might want to have from the IMAP side of things.

Best regards,
Torben Nehmer

1 Like