Disappearing Emails / Desync

There are multiple reports of emails and drafts going missing from folders, reverting to unread, or otherwise moving around, as if changes made on Mailspring are not syncing properly to the IMAP server.

This may be related to The Eternal Sync Bug, but needs to be diagnosed separately.

NOTE: There are particularly good notes here:

No messages in [Gmail]/Starred and missing other mails from random time periods · Issue #719 · Foundry376/Mailspring · GitHub

Per the request on the the now-closed “Emails Disappear From Mailbox” issue, I’m reposting a record of my attempts to debug this issue .

This issue meant I couldn’t really use Mailspring, so I don’t have more recent experience of the bug. I am happy to reinstall if there are specific diagnostic steps it would be useful for me to follow and record. My report circa September 28, 2020:


OS: Pop!_OS 20.04 LTS
Mailspring: v1.7.8
Third-party plugins: none
Email provider: hushmail over IMAP


I think my mail client might be moving things out of a place that Mailspring recognizes as the inbox in some non-obvious way?

Even without refreshing the cache, using the web client to move emails in the inbox “to Inbox” will cause them to reappear in Mailspring. (Ditto emails in “Sent” and “Archive”.)

All the things I tried

In ~/snap/mailspring/common/mailsync-XXXXXXXX.log I saw a bunch of log lines with the content Unlinking messages WHERE remoteFolderId = ? AND remoteUID < ? no longer present in remote range..

Those lines (and Emails Disappear From Inbox · Issue #304 · Foundry376/Mailspring · GitHub) made me wonder whether my previous use of Geary had somehow moved those into a virtual / remote folder other than Inbox (even through it didn’t look that way in the web interface). I tried:

  1. Manually selecting all of the emails in my hushmail inbox and selecting “Move to… > Inbox”.
  2. Resetting the Mailspring cache under Edit > Preferences > Reset Cache.
  3. This caused all of my emails to appear in my Mailspring inbox for the first time. Yay!
  4. But then they all disappeared, without any obvious trigger action a few minutes later…
  5. I tried a full reinstall (with snap remove mailspring), but to no avail.
  6. Everything again disappeared after a few minutes, without any obvious trigger action (deleting / archiving / etc.).

The exact lines in the mailsync log corresponding to the messages being deleted (I had them running with tail -f) appear to be this background worker:

[2020-09-28 17:53:00.650] [background] [info] -- Removing 100 unlinked messages
[2020-09-28 17:53:00.771] [background] [warning] [SLOW] Transaction=deleteMessagesStillUnlinked > 80ms (161ms, 0 waiting to aquire)
[2020-09-28 17:53:00.783] [background] [info] -- Removing 42 unlinked messages
[2020-09-28 17:53:00.841] [background] [info] Sync loop complete.

I guess the worker doesn’t execute for the first few minutes after I reset the Mailspring cache?

Anyway, I don’t really expect to be able to use Mailspring like this, but it’s much nicer than the other Linux desktop clients, so let me know if there are other debugging steps I should try?

1 Like

This one may be related: I noticed in the last month or so that, occasionally, threads that are supposed to be in my inbox end up showing in the trash folder.

I am on Manajro, kernel 5.10, and using the AUR mailspring version. The last update is from Jan 23.

Initially I thought that mailspring was classifying as “trash threads” those that contain even a single deleted messages. However, it seems this is happening with threads where deletions have never happened.

I am attaching a screenshot from my trash folder:

There are no actually trashed messages: mailpring shows an empty thread and notifies me that there are messages not in spam/trash (which is correct, in fact all of them are in the inbox for one of my accounts)

In all cases, I never deleted any message: it is strange (and frankly a bit worrying) to see them appear in the trash folder. Threads such as this are also not covered by searches, unless I explicitly add the condition “in: trash”, which considerably complicates finding content.

I have both a Office365 and a Gmail account, and the problem seems to appear on both.


Recenly, i sent an email to prospect client, and when tried to to find it i could’t. Nowhere…

I had to ask the recepient if he got it and he did.

I just sent another important email to another client and the same happened.

The email is nowhere… Neither in Mailspring nor in Gmail (the linked account).

I think this is a very important bug.

Any ideas where i can find these emails?

Windows 10
latest mailspring version

There is definitely a flaw in how Mailsync stores sent mail. It results in duplication in some cases, and deletion in others.

@chmatonakis I think your situation might actually be a bit different from this bug. Would you be willing to create a new bug report about this? The template does ask for some additional info. (P.S. We need the actual Mailspring version number. “Latest” won’t help us as soon as the next version comes out.)

Same issue here - Mailspring v1.8.0-8983cda2 client, running on Ubuntu Desktop 20.04.2 LTS

Mail server is running Dovecot virtual folders. Messages ‘disappearing’ from inbox in the Mailspring client, but still visible in other clients and using Webmail.

Happy to provide more info if it will help, as I like the client but cannot use it with this problem

Almost every day 1-2 emails that I already read, appear as unread. I tried to rebuild the cache but the problem persists. I am using Windows 10 and installed Mailsrping through chocolatey. Any ideas on how to fix it?

1 Like

Confirming this is still the issue in 1.9.1.
Still cannot switch back to Mailspring as missing emails is the critical issue.


New to mail spring. Facing this issue with a Zimbra server. Emails that are in the parent folder dissappear, while emails in folders do not disappear. Not a duplication issue related to virutal folders as discussed on github thread

1 Like

@orestis1234 @ipa @ksk Thanks for helping confirm this. Please don’t forget to Vote for the issue at the top; that helps raise the priority.

Thank you also to everyone for your patience. Hopefully we can get this resolved at some point. (Remember, we have very limited development hours.)

Voted. This is the only reason I can’t use Mailspring as my main mailer app as well.

My intention is not to pressurize the developers, but I would just like to know if they consider this issue a priority or not?

This is a critical issue, any ETA on this? I can’t use mailspring as my only email client because of it

1 Like

same problem here… please vote for the issue if you haven’t already

Voted. Mailspring is really great but the not synched drafts and the threads that disappear when they have a single trashed email, make it very difficult to use it productively.

(Enviroment: Mailspring 1.9.1 - Mac / Gmail)

Tried and tested version 1.9.2. Unfortunately this issue still exists in this version too.

Still have the issue with 1.9.2 with OVH mail. Same issue for the last two years :frowning_face:
Please consider resolving this !

1 Like

Any news on this? Still a big issue

I’m experiencing this issue as well, using Mailspring 1.10.4 on macOS, with posteo.de. At a certain point, due to an unknown cause, emails older than a certain date stopped appearing in my inbox. They still appear in my inbox on the posteo.de webmail site, and on all other email clients I’ve tried.

Unfortunately, I won’t be able to use Mailspring until this issue gets resolved. Other than this issue, Mailspring is by far my favorite email client that I’ve tried, so I hope the team is able to resolve the problem soon. Best of luck.

1 Like