Error with the local database during update

I have no version 1.9.2. Can You send me link to download this version?

Hello, you might be interested in seeing my post here: Database Error and unable to launch app after installing V1.10.0 - #11 by Predeactor

1 Like

Hi Mate,
Thanks a lot, your solution works!

1 Like

Hi @Predeactor ,
I tried this option but now the program doesn’t open at all. And, I can’t even uninstall it… any ideas? :frowning:

Hello @andreacoyotzi, I apologize that this happened when trying my solution :slightly_frowning_face: I suggest a complete reinstall of Mailspring at this point…

However, here’s a slight word of caution
Yes, I’ve tried uninstalling Mailspring by myself to see if the uninstalling solution I gave you will work, of course, it worked for me without loosing your data, but again, this is my solution, it worked for me, on my computer, and I hope it will work for you too, but if not, I’ll be sorry to tell you you’re on your own at this point… Let’s hope not and keep finger crossed!


First of all, try to uninstall Mailspring using by going to your Windows Settings, selecting Mailspring, and clicking uninstall, I do not expect this to work, but if it does, you can reinstall the version 1.9.2 of Mailspring!

If this didn’t worked, here’s what I’ve done:

  1. Do Windows+R, and type %LocalAppData%/Mailspring
  2. Delete EVERYTHING in this folder
  3. Try opening Mailspring using Windows Search bar, an error should be raised, telling Mailspring couldn’t be found, close this message. If you do not have this message, it is most probably that your Mailspring instance is installed somewhere else I am unaware of.
  4. Install Mailspring, see below

Yes, there will still be some files at %AppData%/Mailspring, but these contain your settings, config, etc… Better leave it there.

Installing 1.9.2

You can check this page and grab MailspringSetup.exe if you’re on Windows, or Mailspring.dmg for Mac (I doubt you’re using Linux) - Release 1.9.2 · Foundry376/Mailspring · GitHub
This will install Mailspring again, on what I consider to be the today’s stable version of the app. Of course, after the app open, ignore the update (The app will download the update but not install it, leaving you on 1.9.2)

I hope the best for you, and wish everything will work just fine :slight_smile: Good luck!


@Predeactor THANK YOU!! This worked and I have the mail back. One last question, do you know if it’s possible to delete from the folder the Update.exe file without problems? I’m asking this because I did this and all went well but it seems to be updating the Mailspring to 1.0 randomly and then I have to follow these steps again. Is there a way I can avoid that? (I just guessed deleting the Update.exe would do it but not sure if deleting that file will mess with somethign else)
And again THANK YOU so much for this answer!

1 Like

Hi, I’m glad to hear it worked just fine for you!
I do not recommend deleting any executable files as it might come against the application’s integrity, and as such, causes problems at some point. I assume that if you do that, you’ll revoke update possibilities.
But all I also can tell is, try it and see what happens, I’m unavailable for most of the day from now on, so I can’t really test anymore :slightly_smiling_face:
By the way, does the update install automatically by itself without prompting you an update?
If so, can you try checking your Mailspring’s settings for a setting related to automatically installing updates? I’m unaware if it exists though.

1 Like

Thank you! The second option worked for me! Thank you so much!
It feels so good to get MailSpring back agai! It’s when you loose it for just 2 days that you realize how you love this app! :smiley:

Thanks again for your help and your amazing work! Have a great day!

1 Like

@Predeactor Thank you for the tip, it worked for me too! (win10 x64)

1 Like

@Predeactor do u know if there’s a chance to delete or block the option of downloading automatically the update? I reinstalled the previous version but it downloaded the newest version and even when I ignored the popup message to update, it seems the update was applied automatically, so, I’m stucked with the newest version again, unable to open mailspring

[[Solved]] Database Error and unable to launch app after installing V1.10.0 - #31 by working-name

Hi, just updated my post, you can check it again :smiley:

1 Like

Awesome!!! it worked!!! thank u @Predeactor

Hey but when the devs release a new patch should i’d rename the update.exe again?

I think this is the best to do, yes, I’ll edit my post to underline that point! :slightly_smiling_face:

Thank you all for the solutions, here it worked!

@Predeactor Thank you so much for your repleid and all the help.

Unfortunately for me the error happens erverytime I restart the computer. That is the reason I wanted to know if the Uninstall.exe could be deleted. Whe I start Mailspring it asks me if I want to download the update, which I say no. And in the preferences there is nowhere where I can modify any updates that it does when I restart the computer. For now what I have to do every time is when I come back uninstall it and re install it so I can keep using it. That is, every time the computer is restarted :grimacing:

Do you have any suggestions to what might be happening?

And again thank you!

Hi again
It appears that renaming Update.exe to Update.exe.old in your %LocalAppData/Mailspring directory will both not have any issue on Mailspring and will avoid the app to update itself everytime!
So please, rename the following file.

When the developers of Mailspring will push a fix for the application, I suggest you to rename this file back to it’s original name, to let the application update normally.

Hope this wil help you again! :smiley:

1 Like

There is a fix available on github from a member who’s recompiled the broken libraries

be nicer if this was more official and came from the devs but you know

Hi again,
Thank you for your reply :slight_smile:
Unfortunately renaming the file from Update.exe to Update.exe.old in the%LocalAppData/Mailspring directory didn’t do the trick :upside_down_face:

I hope the developers come up with fix in the near future, for now it seems I’m stuck with uninstalling and reinstalling Mailspring everytimes I restart the computer :woman_shrugging:t4:

At least everythings is there how I left it once it’s reinstalled so it’s just a 10 min things I have to do. Unless there is othe option?

In any case @Predeactor thank you for all your help!

The developers have made the fix you’re talking about. You can get it at :slight_smile: